Blinking red and can't upload firmware

Hi everyone.

I’m with this problem for a few days now and I had no luck with any topic here. :frowning: So I`m posting it to see if someone can help.

My Photon was working perfectly. I flashed the Web-Connected LED example to play a bit with my Photon. All good.

Then I left the room for a few minutes. When I came back, the Photon was blinking red. I tried re-plugging it. Still blinking red.

I started googling for a solution. I put it on DFU mode (although when I tried putting it on DFU mode, I got some yellow-red-ish blinking). Then I tried several commands, with no help.

Now, after lots of attempts, the photon will not even blink anything when plugged. Only if hold setup when plugging in.

Check video here

My particle CLI version is 1.29.0
My dfu-util version is 0.9

Thanks in advance!

Let me ping someone that might be able to help, @rickkas7 or @ParticleD are you able to assist?

This may be a hardware failure. You should create a support ticket.

1 Like

@romulosilva, I can’t be sure but is the metal lid on the P0 module (with the Particle logo on it) deformed. That is, is it pushed in slightly?