Photon Setup Failed at "Verify Product Ownership"

Done to no avail.

Ping…

Any progress on this from Particle? Do the particle people have a bad unit to evaluate? What do we do with our non-functioning photons?

Just a heads-up that we’re discussing this thread at Particle today.

A factory reset only resets the application to tinker, but not the system firmware.
Upgrading to 0.4.2 is essentially wiping and starting from scratch. Please try the upgrade again, double checking each step, since it’s easy to mix up the files.

Is it possible to combine the multiple files into a single .hex that can be programmed with a single step (even if that means we have to forcibly pad the gaps because dfu-util can’t grok discontiguous file contents) ?
I think this might simplify the recovery process.

1 Like

Good timing. I just got some time to play with this today and tried the key regen from this thread, and it fixed my Photon!!!

I did get one warning that makes me think this fix might not last:
dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!

Great to hear that @TogaDriver! :smiley: If you use the program-dfu make target when building locally, we do create the DFU suffix and program it the recommended way, but the .bin file without the suffix can be programmed just fine as well. In other words — no need to worry about that warning, it’s totally benign. :+1:

I have given up and requested a replacement. I can not spend this amount of time on a $19 item. If another one does the same thing, I’ll try a cursory recovery up to my 15 minute time limit, then return.

I’m surprised Particle did not want the pooched Photon back for forensics.

Thanks everyone for their help!

@steelydev, You might give one last try with the instructions below. They finally did the trick for my photon. After doing this and rebooting the device I used the IOS registration (which had not worked) and it worked perfectly.

Using particle, first generate a new key:

particle keys new
Then put the device in DFU mode and flash this new key

dfu-util -d 2b04:d006 -a 1 -s 34 -D device.der
Then reboot the device and it should connect to the cloud.

1 Like

Just to add to this topic, I had the exact same issue as everyone here. iPhone app, CLI serial, and CLI wifi all failed with “invalid claim code.” Finally I tried the “particle serial wifi” method explained here, and my Photon connected, rebooted, flashed, rebooted, and then just connected and apparently claimed itself for me using my CLI credentials.

This is definitely an issue with a number of photons and is creating a lot of headaches for people, especially those who don’t have time to jump through setup hoops.

Just received 10 photons and keen to get the first one connected - now seeing the same problem as others. When I tried the IOS app, it fails at the last step (Verify device ownership) and a retry does not work as the Photon’s network does not appear in the list of networks on my phone. I have to reboot the device, but the same issues appears (fails to verify).

I then tried the CLI and get this message:

Photon team - I know a serious amount of effort has gone into the Photon and I am willing this to work. I can see that by using low level commands, some of these cores do start to connect, but this is far from ideal. Can we have a response as to what is being done to identify how big an issue this is and what we can do collectively to resolve this?

second core has also failed with the same issues. I can provide details if required (ios, network, etc).

Is your machine connected to the internet and you logging in to an account?

1 Like

From the App
The app requires login, so this was the case with the app attempt. My machine is connected to the internet (same machine I am emailing from).

From CLI
When I ran ‘particle setup’ it confirmed I was already logged in. I have also tried logging into my second account and I get the same response. The photon is flashing blue. I am seeing an error:

Setup is easy! Let’s get started…
It appears as though you are already logged in as xxxx@xx.xx
? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet.

I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We’ll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You may lose your connection to the internet for a moment.

Potentially unhandled rejection [2] Unable to find mac address in response (WARNING: non-Error used)
? Found “Photon-TQJL”. Would you like to perform setup on this one now? Yes

! PROTIP: You will need to know the password for your Wi-Fi network (if any) to proceed.
! PROTIP: You can press ctrl + C to quit setup at any time.

! Woops. Something went wrong connecting to Photon-TQJL. Please manually re-connect to your Wi-Fi network.

Although I know my machine is connected to wifi, I disconnected and reconnected. I get the same result, but I no longer get the error message (unhandled rejection [2])

Alright follow the steps here: [Howto] Setup photon if docs step fail with your Photon blinking blue and connected via USB

The photon rebooted, now flashing…

Response when I try to save the core id (id obfuscated):

Thanks! Wait while I save those credentials…
Done! Your device should now restart.
iMac002:natter kevinhankinson$ particle device add 19002xxxxxxxx343337373xxx
Claiming device 19002xxxxxx343337373xxx
Failed to claim device, server said { ok: false, errors: [ ‘device does not exist’ ] }

is it flashing cyan?

It is flashing the color in the photo - more cyan than blue!, so yes I think so.

Ok if it is flashing means there’s some issue trying to complete a successful connection. A successful one would be breathing cyan.

Does it keep flashing cyan? Any red flashes?

when I reboot, sequence is now…green for 5 seconds, then cyan.