Photon Serial Interface Doesn't Work after Online Setup Tool Flashing

I've run into some further issues with the online setup tool and the SparkFun Photon RedBoard. I've noticed that when I use the setup tool (Device Setup | Tools | Particle), and flash the device, the device stops responding to the usual serial commands. I've included a trace below of using the USB serial debug tool before and after using the setup tool in order to get the mac address. (I've tried other serial monitors, cables, device OS versions (2.3.0, 2.3.1, and 3.3.1), etc.) I made sure to be in listening mode (blinking dark blue). Is there a way to get the old / normal menu to pop up? The new menu that pops up doesn't seem to have a mac address option. Is there a different way I can get the mac address?

Is there a specific OS version I need to use?

The CLI also struggles and complains about incorrectly structured JSON objects and that it cannot complete commands such as "particle serial mac".

I'd appreciate any help. Thanks!

You should probably use the setup tool instead.

I think the problem you are running into is that setup tool doesn't flash tinker, it flashes a special troubleshooting app and that might be causing your problem.

Also you could use Device Restore USB since the device is already set up.

My issue with using is that I need to be able to force claim my devices and also I don't want to add it to a product. I think that setup tool forces the device to be added to a product.

I have not looked into Tinker. And I don't remember if I tried the USB debug tool but I'll try again later today. Thanks for the tips.

In that case, run the docs setup tool to force claim, then either use Device Restore USB or flash tinker using particle flash --usb tinker with the device in DFU mode (blinking yellow).

Because the troubleshooting firmware is outputting debug logs it's probably interfering with the CLI serial commands.

Ok both those options worked. Thank you very much for your help. I had one more follow-up question kind of related to this thread. Is there an easy way to set up more than one Wi-Fi login with this setup? I suppose I could just flash it twice and that would work..

Hi, there's some information on how to do that here:

(this is for the Photon 2 but it also applies to the Photon)

For the Photon 1 and P1, using particle serial wifi from the Particle CLI is the easiest way to add multiple credentials (up to 5). You can also set up the device again to add multiple credentials.

For the Photon 2, P2, and Argon you can use that or the Configure WiFi tool but that web-based USB tool cannot be used with Gen 2 devices.


Ok that is about what I expected. Thanks yet again for your help :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.