Can't setup brand new photon- Internal Error

Hi there,

I just received a brand new Photon and I tried to set it up using my iPhone and the Particle App and it comes up with the error

“Setup process couldn’t disconect from the the Particle Device Wi-Fi network. This is an internal problem with the device, so please try resetting your Particle device and putting it back in blinking blue listen mode if needed.”

I have obviously tried resetting it but I always get the same error.

Any help would be amazing.

Hi @griffinweir,

Seems like the mobile application is not working well for you. Can you try install Particle CLI to setup the Photon?

Thanks for the response @kennethlimcp

I think I have installed it but when I run
’Particle serial identify’

It says no devices are available via serial. I may be missing a step here.

Is the Photon in listening mode (blinking blue)?

I’ve tried in both blinking blue and blinking yellow

Blinking yellow is DFU mode and serial commands doesn’t work.

Can you place it in Listening mode (blinking blue) and try particle serial identify

Tried in blinking blue and still didn’t think anything was connected. I tried a wireless set up but that didn’t work either.

Can you try another cable?

Good thinking but unfortunately it’s the same result.

Ok when you place in DFU mode, can you try particle update?

it also doesn’t work it says-

Cannot open DFU device 0a5c:21fb

There was an error trying to execute DFU utilities

Error code: unknown

Was there a resolution to this problem?