Photon Problems

Wow… where to start??

I have 2 brand new Photons - can’t get either to work. Here’s everything I’ve tried:

  1. I got one of them connected to the cloud a couple days ago, but then I couldn’t flash it using the online IDE (either in regular mode, or safe mode). I did a factory reset and now I can’t even get it on my WiFi. :unamused:

  2. I’ve put both Photons in DFU mode after all the issues, and they are both running 0.4.4 (latest). DFU firmware updates are the only thing that seems to work reliably. When I run “particle setup” from the CLI, I keep getting errors saying “There was a network error while connecting to the cloud…” and then it quits… every single time. Now I can’t even get either photon on my network. And please don’t even ask about trying with the iOS app… because that never works. :confused:

  3. When I did have one of the photons on the network earlier, I couldn’t flash it with the online IDE. The LED on the photon indicated it was connected (breathing cyan), but online (under devices) it doesn’t show the photon as being connected. Whats even worse is that one of my other boards (a custom P1 board) shows up as being connected to the cloud when its just sitting on my desk… unplugged. So a device that is powered and connected doesn’t show up, and an unpowered device shows up as being connected. :tired_face:

  4. I’ve tried 8 different DATA capable USB cables. Some work for serial comm, some don’t work at all, some work partly during setup… its just a mess. And all these cables seem to work fine with every other USB device. So whats the deal with Photons and P1s being so sensitive about USB cables?

  5. Side question: Are there any harmful particulates/vapors/dust that can come from a Photon? Just wondering if I need to wear a mask when I smash mine to pieces!! :stuck_out_tongue_closed_eyes:

hey @ElementOrange:

Please contact me in Zendesk I can get things squared away for you.
use this link:
and click the help button in the bottom left corner.
ping me here so i can look for the email.

-Corey @ Particle

Hello Corey - I have the exact same issue as documented by the original post above. I have tried for weeks to get my photon to using the iphone app (never works…a spinning icon keeps cycling next the the Photon-XXXX text in step 2 - and when I try using particle setup on the CLI, I get “There was a network error while connecting to the cloud”. I can get it to the online breathing cyan state by manually doing the “particle setup wifi” routine … unplug/replug in the photon, it goes breathing cyan. However, I can never get the Build IDE to actually flash new firmware to the photon…It says “Ready” after the Flash push…but the new firmware never runs. Please help!