Photon getting really hot

One of my photons is getting really hot (hot enough that I don’t want to touch the pins or underside of the PCB)

So far it seems to be working ok, I can use it, flash it etc… But it seems to hot to be running right…

Im happy to admit (well not happy!) that I did kill one of my photons by shorting a pin to a >5v source, that one suffered the same heat symptom (it gets really hot) but I know I’ve killed it because all I get from it is a red light SOS, can’t flash etc…

The other photon hasn’t yet been connected to anything other than a USB cable!!

Would really appreciate any advice?


If you’re getting the SOS from your “killed” photon, it may not be dead. There’s quite a lot of code needed to make that SOS light, so it seems to be running. I’d suspect instead buggy application code. Have you tried running that photon in Safe Mode?

If I’m honest I’d kind of given up on that one because of the high voltage short. It would book and run user code until I upgraded the firmware to 0.4.4 (via dfu-util) since then it boots, runs my user code for about 2 seconds then starts flashing red then reboots and starts the cycle again. Until I flashed 0.4.4 it would boot and run but I couldn’t flash via cloud or USB, and it wouldn’t show up a running in the particle iOS app.

It’s the fully functional one that I’m worried about because of the heat… It’s almost to hot to touch!



Sorry to keep offering help on the photon that you’ve given up on, but have you tried safe mode? If you can get it breathing magenta then it seems the photon MCU is good. There might be some GPIOs that don’t work but the unit might still be useful. Of course, if you’d prefer to just let it go, that’s equally fine.

I don’t know about the heat - I imagine something to do with the voltage regulator - I’ll leave it for the hardware experts to comment on that.

Thanks @mdma, I’ll more more than happy if I can get it working again so will try safe mode and see about the heat.

Just been and had a poke at the functional one, it was so hot that I couldn’t hold on to it so I’ve had to turn it off!

It’s just a little odd that they are both getting so hot, I can understand the one that I shorted, but as the other one hasn’t been used at all (not connected to any hardware etc… Just USB for power) I’m a little concerned.

Thanks again

What kind of power source are you using, many of the cheap USB power supplies may be bad. Have you tried running it off a computers USB port?

I’m currently running it off my MacBook pro’s USB, also tried it from a USB socket from my desktop and the adaptor that I used for my raspberry pi so I don’t think it’s the power source.

Hey @JohnM88 could you snap a quick photo of the top and bottom of the Photon you’re having trouble with? Physical defects are the most likely cause of any issues you’re seeing.

1 Like

Hi @will here are a couple of photos of the offending photon, I’ve got a ticket open with the support team, they’ve just asked me to check the current draw of the module… When running on a 5v supply it’s currently pulling between 610mAh and 620mAh :frowning: this is while running tinker so connect to wifi but not doing anything at all!! No idea why it’s pulling so much current but would explain the heat I guess…


Also, I didn’t see you mention this, sometimes it’s not the source of usb power (you mentioned your macbook and another desktop) but the actual USB cable itself. Sometimes they can be bad and cause overheating. Try another, different, one?

Hi @harrisonhjones the conversation I’ve been having with support suggested the same thing. I’ve tried another cable and I didn’t make any difference. Also when testing the current draw I’ve used a variable power supply and powered the photon via the Vin and gnd pins so avoided the USB cable completely (so that q multimeter could measure the current draw)



I assume it also got hot when you tested it via VIN? If so, can you reliably source 3.3v? If so, the next step would be to try powering it via the 3.3v pin (only give it ~3.3v) and see if it gets hot.

I’ve just tested with 3.3v, this time the current draw was higher, floating between 680mAh and 700mAh :frowning:

Just to be sure I’ve checked that the meter isn’t giving out odd readings, I’ve tested the draw of an arduino uno powering a single led and running very little code, that reads ~58mAh so the readings seems to be right…

Thanks for your help

Those mAh seem VERY high to me.

I am curious about the one you over-volted a bit, if you do not mind my asking:

  1. Which pin(s) did you hit?
  2. Is there any visual sign of damage?

The reason I ask is that I accidentally shorted 12v to a couple pins on one of mine (mis-wired the MOSFET for an RGB LED strip) and now most of my pins no longer seem to work (D0 and D6 are proven OK though). D1 - D5 have a “wet” or “glossy” look to the top of the PCB (they are not wet of course) around the pins. None of the rest do. The Photon also is substantially hotter than others I have doing comparable work. I put a heatsink on it but can get a reading of ~150F where it meets the metal shield.