Photon unable to connect and very hot

Recently my Photon started not being able to connect to my network. When I supply power to the Photon it shows solid white, then blinking green, blinking blue, followed by very fast blinking of white (can’t tell if it’s incredibly fast blinking or solid white).

The photon also becomes very hot, and is too hot to press either the SETUP or RESET buttons. Any ideas? Does it sound like there could be a short somewhere? Nothing hooked up to the Photon except for the USB for power.

Thanks in advance!

If the Photon can boot up and go through the series of process (inferred from the blinking of lights) that means it’s still functioning properly.

Hmm… interesting. I tried to reset to factory setting, but that procedure seems to not work, either. Any other thoughts on how to reset it?

When you say factory reset does not work, what is the symptom that you observed?

You can use Safe mode instead:

So I was able to follow the steps for safe mode, but now it is only blinking white. Unable to get it to blink blue to restart the device setup. Any thing I should be doing after the Safe Mode? Thanks!

Hmm… It sounds like your Photon might be cooked though…

What is the USB power source? a computer USB port?

I’ve tried both the USB to a standard wall outlet, as well as to my computer’s USB port. I think you’re right about the Photon being fried…