Photon does not work with new router

I updated my router, and both Photons fail. Stuck flashing fast cyan.
particle device doctor failed right after antenna setting, error “undefined”

I used particle serial wifi to change SSID/pw between old/new routers.
Tried simple Tinker, to make sure it was not my code.
Switching back to old router worked, but is only a temporary solution.

New router is ATT ARRIS BGW210
Both 2.4 and 5 GHz

From reading older posts, possibly an issue defaulting to 5 GHz, but no obvious fix.

I updated photon to firmware to 0.7.0. No change.

Hi @rygh

I found the setup guide for your router here but it does not really cover any settings etc.

The only thing I can think to try is to completely wipe the Photon’s credentials in listening mode and reenter them with only the new router turned on.

If that doesn’t help you may have to contact your ISP for help changing the two bands to different SSIDs.

I tried the wipe earlier by holding setup 10 seconds, which I think is what you mean. No luck.

Yes, still poking around trying to change router. But not so excited about that.

Note that every once in a while, it flashes yellow, then flashes green, then back to flashing cyan.

Check your port settings, if you can find it in your router. I believe it is connecting to Wi-Fi, as it gets past flashing green, but fails in the cloud connection. @bko, may be able to confirm the port, but I believe it is 5280, or a quick search on the forum will tell you.

There are no outgoing port restrictions on my router.

I added a guest SSID on the 2.4 GHz only, set it to that, and it worked.

I also figured out how to have separate SSID for each frequency on main account,
but I would not consider that a real fix, since that means other devices cannot
switch on the fly.

Thanks for the help!


Just a quick note:

While a bit of a pain for a hobbyist, it seems like this problem is
a total showstopper for someone going to production.

My router is not some fancy esoteric one, it is the free one from ATT.
Sharing SSID between 2.5 and 5 GHz will be the norm.

Plus, I was lucky that I could put a separate guest account on 2.4 GHz.
Splitting your main SSID is not really a good fix.
And again, not something to even consider having lots of regular customers attempt.