Flashing Green stuck on one WIFI setting

Well one of my photons keeps flashing green. No matter if I try to go to Safe mode or do a reset, it just flashes green while in the presence of other photons which are connected to the same wifi. So it seems it’s not connecting to the wifi. I’ve tried all the different reset options but it just flashes Green! I can connect to it with the terminal window but there’s no ASCII feedback to debug it with so I really can’t tell what’s going on. Does anyone have any ideas. I’ve read through Kevin’s notes and it seems that it’s replicating exactly what 2sharkb’s Photon did. I’ve gone through all the reset options. I’m not a novice at this. I do know the buttons are working fine and I’ve checked them with a multi-meter. I also changed the USB cable and even plugged in the battery back up fully charged but it doesn’t work. It just flashes GREEN. The only difference between my case and 2sharkb’s case is that I can access it with the terminal window… Just no data seen. Any help would be great. I’m ordering 3 more today to get my project enough on backup. still wanting to fix this problem. Thanks in advance…

Have you tried particle update and particle flash --usb tinker?

The lacking data in terminal window might come from the default SYSTEM_MODE(AUTOMATIC) which only runs your code after the device has made it to breathing cyan.
Or have you got non-AUTOMATIC or SYSTEM_THREAD(ENABLED) in your code?

How many other Photons (and other devices) are connected at the same time?
Have you tried disconnecting the other devices and reset the router before retrying? This is in order to rule out that your router has run out of free DHCP addresses for a new device.