[Solved] New Firmware (0.5.1) Breaks WPA2-AES?

When I upgraded my Photon to 0.5.1, it stopped connecting to a WPA2-AES network it had no difficulty connecting to previously. When the firmware was upgraded, the LED blinked green for 10+ minutes, and when I tried putting into into setup to use “particle serial wifi”, it blinked green and then went back into setup. Downgrading to 0.5.0 made the wifi work again. I have tested this by upgrading and downgrading twice. Does anyone know how to fix this? I would rather not have to compile for 0.5.0 on the web IDE.

Sorry to hear of these troubles. Which Wi-Fi channel is your router broadcasting on?

Not to minimize your troubles, but to hopefully encourage you that there is not an issue in general with 0.5.1 and WPA2-AES; I’ve been running this same configuration and have not had any issues with several of my Photons. I’m in the USA so my router sticks to channels 1-11. If you happen to be in Japan and by any luck have had your router on channel 14, 0.5.1 will not connect to it by default. The easiest fix might be to set your WAP channel to something other than 14. If you want to leave it on auto in japan you will need to set the Wi-Fi country code to WICED_COUNTRY_JAPAN per instructions here in the first post of this PR: https://github.com/spark/firmware/pull/942

@sdijoseph hope all is well. Please let us know your WAP details when you get back to your Photon :smile:

Sorry, I tried updating again today and it mysteriously works fine now. Thank you for your time.


Awexome to hear it! Please let us know if the problem pops up again.