Difficulty connecting Photon to WPA2-Enterprise network


#1

I’ve been trying for a handful of hours to connect a photon to a university wireless network, with WPA2-Enterprise (PEAP-AES). I have checked the few other posts in this area, but unfortunately none seemed to help my situation.

I have tried connecting using both particle setup and particle serial wifi. I’ve tried letting the photon find the network itself, as well as manually entering the SSID. I suspect I may be having issues with the CA certificate, but it’s hard to be sure of anything, as the photon just gets stuck at the “attempting connection” phase.

  • Does anyone have suggestions for debugging this process?
  • I have tried many variations of config, but I know, from my phone’s connection, the correct username and password, as well as another confirmation that PEAP-AES is the correct strategy
  • Is the (y/n) prompt for “Do you want to upload a certificate?” prompt looking for an Additional cert, or is it asking whether I want to authenticate the network at all? (I don’t)

Thank you in advance for your insights!

Edit: I’m using firmware 0.7, just for reference


#2

Just to make sure, you have followed the process as outlined here?
https://docs.particle.io/support/particle-devices-faq/wpa2-enterprise/


#3

Yes I have, although it seems some of the prompts on that page are a bit out-of-date, and are phrased slightly differently in the most updated particle-cli

I hadn’t previously noticed the TinkerDebug070 troubleshooting firmware though. I’ll try flashing that shortly and get back to you when I do!


#4

@ScruffR looks like I’m getting 1007 “Not Keyed”. Any ideas how to interpret that?


#5

I have to defer to @rickkas7 for that


#6

I have a custom Device OS build that was specifically made to debug WPA2 Enterprise issues – as you’ve discovered they’re very hard to troubleshoot due to all of the different possible configurations. If you continue to have issues and the TinkerDebug bin (which I am not familiar with) doesn’t get you there, file a ticket here and I’ll send it to you.