Photon cannot connect to WPA2 Enterprise

I have a photon in OS version 1.2.1, but I have trouble connecting to WPA2 Enterprise wifi. I was following this tutorial: https://docs.particle.io/support/particle-devices-faq/wpa2-enterprise/, but the device blinks green and then goes back to listening mode after I setup all the credentials.

I tried to run the test application posted here: (Establishing a test environment for WPA2 Enterprise), it gives error: NETWORK_NOT_FOUND.

Then I tried to wifi.scan() to search for my wifi, my wpa2 enterprise doesn’t show up, but it appears when I was using the cli “particle serial wifi” to scan.

I also couldn’t find this wifi when I do “particle setup”

@lailaitilee Welcome to the Particle Community.

it gives error: NETWORK_NOT_FOUND

I presume you changed the hard coded WAP name to your WAP details?

Then I tried to wifi.scan() to search for my wifi,

I have never tried a wifi.scan() for WPA Enterprise WAPs so I can’t vouch for ever having this working.

I suggest you log a support ticket with Particle - this is a problem that needs more user demand to ensure scarce engineering resources are directed to regression testing and determining the reasons for it not working. You may have seen other topics where the behaviour has been narrowed to a timeout on the photon and/or it is rejecting the authentication success returned from the RADIUS server. Sorry I can’t be more helpful.