Photon: cloud connection problem

I have a connection problem with the photon.
It connect to the internet and after that blinking red 3 times.
As I read in the manual this is a problem to connect to the cloud, but in the other computers on the same network there isn’t a connection problem with the connection.

How can I debug the problem?

@iftach, you could start by posting your code! :wink:

1 Like

Thanks for the replay!

It’s a simple code that run in automatic mode, so i figure it doesn’t metter and it also the same result in safe mode.

@iftach, red blinking (SOS) is an indication of code problems typically. Are you saying that putting the photon in safe mode give you SOS blinking as well?

Yes the same is safe-mode also.

As it’s write in the getting started guide:
3 red blinks: Connected to the internet, but could not reach the Particle Cloud.

its seem to be some problem with the router because when I connect the photon through the hot-spot in my phone it’s work fine.
But all the other devices in the network is working.

Any idea?

Maybe your router is blocking port 5683?

Hi @peekay123 @mdma ,

I’m facing the same issue. 3 Red SOS: Connected to the internet, but could not reach the Particle Cloud.

I tried several methods to troubleshoot the problem but nothing happened :disappointed:

Problem: My photon was working perfectly from last 6 months but suddenly, it shows RED SOS error (i mentioned) then I unclaimed from my account. Again, I try to setup the photon but setup failed at “verifying product ownership”. Due to this, I’m not able to claim again.

On the other hand, When I read below statement, I though that it may be code problem, so I tried to flash the device to tinker through serial (usb).

Despite of successful flash, it shows same RED SOS error.

I also tried the local flash, both system+application firmware through build system in dfu mode. Again, same error. So, I think, it is not the code problem.

One more thing- When I try to put the device in safe mode, it doesn’t stop on magneta, rather it blinks green then again cyan-red-cyan SOS error.

Ultimately, neither claiming nor connecting to cloud.

What should I do?

Just to clarify, since that confusion seemed to exist in the previous posts.

Do you see three red blinks between cyan or do you see a red SOS (… — …) followed by three red blinks and SOS again and the device restarting completely?

3 red between cyan.

So it’s not SOS
https://docs.particle.io/guide/getting-started/modes/photon/#red-blink-basic-errors

Have you confirmed that the port is open and the cloud is pingable via that network?
Have you tried another network?

I confirmed the led pattern again, pattern is rapid cyan -> 3 rapid red blink -> normal cyan blink then again rapid cyan and so on.

yes, port is open and cloud is pingable via that network.

I also checked another devices. They are working well on same network.

You can watch the pattern in this video https://goo.gl/EUM7kl

OK, then again it’s something else.
This is called the red/orange burst and indicates some issues with the keys on your device.

The first thing to try with that is to run

particle keys server
particle keys doctor <insertYourDeviceID>

If this doesn’t help, try searching the forum for red burst or orange burst - there should be several threads.

1 Like

Hi @ScruffR

You solved my problem. Thanks a lot! :blush:

I just did one thing extra- for particle keys doctor command, there was requirement of openssl for windows to execute the command.

Solved my problem too, thanks. :smiley:

I had a flashing cyan light, follow by a quick burst of red/orange. This happened after my battery had did earlier and I found my photon had forgotten the wifi settings. After setting the Wifi again I hada this issue. I already tried installing the firmware again and serial loading the tinker app, but that not helped. Also the particle keys server cloud_public.der particle keys new photon particle keys load photon.der particle keys send photon.pub.pem didn’t help. :smirk:

1 Like