Is the cloud still being worked on? I am stuck in the loop

I get breathing cyan, flashing red, white, blinking green. I have done a factory reset multiple times.

Hi @pcproff

It sounds like the code on your device is crashing. Do the red flashes happen in an SOS followed by a number of flashes that repeats? You know SOS, right, 3 fast blinks, 3 slow blinks, then 3 fast again followed a count of flashes at a different pace. Does this happen after a factory reset but before you add your program to the device?

Blinking green means it can’t connect to WiFi.

Is it a core or a photon?

1 Like

HI @bko,

This is a photon and yes it is SOS signal and after the factory reset I have not uploaded any code and I cannot get my cyan breathing.

If you have the CLI or even just dfu-util installed, you can try installing the system binaries and tinker again. You can look at the releases page here. Things are in flux right now since a major release is imminent but you might want to go for 0.4.2. The cloud may autoupdate your Photon after you connect (flashing magenta for several minutes).

By the way the number of flashes after the SOS tells you fault type. I would think you are getting one flash for a hard fault.


I tried 0.4.4 (latest) 0.4.3 (what I had last working) and now have reverted all the way to 0.4.2 to get my cyan breathing again. I’m assuming this is a known issue?

Hi @pcproff

I was hesitant to recommend 0.4.4 or 0.4.3 since they have some known problems around time functions not compiling. I was trying to get you back to working, knowing that 0.4.4 or higher will likely get released next week sometime.

There are some DNS problems that are being debugged right now too, but I am not sure 0.4.2 has a real fix, just a work-around or lower frequency of bug.

1 Like

OK so again I wake up to my device breathing cyan, flashing red multiple times then SOS flash, then white followed by repeated greens. This is sooooo frustrating with this device I have never had this issue with any other hardware component. How can I take this to the absolute factory reset from the day I opened my box?

Hi @pcproff

I am sorry you are still having trouble. Installing system binaries part 1 and part 2 gets your back to factory new status.

Can you try a different router? Does you router have both 2.4GHz and 5 GHz bands? If so, try renaming the SSID for the 5GHz band so that your Photon cannot try to connect to it. Apple routers (I have a few) are well known for trying to move traffic to the 5GHz band.

If you are still having trouble, then I recommend contacting support by email at

Hi @bko
Link to those binaries? I’m assuming its not the same as holding down the setup button until the white light (factory reset)?

Hi @pcproff

The binaries and instructions are here:

They can be installed using the CLI or dfu-util directly.

1 Like