Permission denied on a particular Photon that worked recently

I followed the support flow through the Support & Troubleshooting docs and it suggested posting to the forums.

I have a particular photon on my account that a week or two ago I could flash via the particle cloud and receive an event stream from. Now I can see the device and its events in the consul but attempts to flash the device via the cloud and receive its event stream via API get permission denied errors.

I tried re logging in and the device appears in particle login with the correct name.

What are you flashing from? Workbench (cloud), Workbench (local), Particle CLI, Cloud API, or Web IDE?

For retrieving the event stream, how did you obtain the access token? Using the oAuth API, particle-api-js, Particle CLI, console, or tool in the docs?

Flashing with the Particle CLI

Flashing firmware to your device "device name"
Failed to flash "device name": Permission Denied

And tokens for receiving the event stream where created with the Particle CLI and it works for other devices jut not this particular one that did work a week or two ago.

Seems to me like it's a cloud-side ownership/permissions issue. I was hoping I could message the device ID to someone from support and have the permissions checked.