Electron Cyan/Red Blinking Status

Hi my Particle Electron is not being able to connect to the cloud to get it set up and claimed. I have tried DFU update, reflashing, new keys, particle keys doctor, particle keys server and lots of other ideas from the community with nothing working so far.

When i run particle keys doctor I get the error that I don’t have permission to send to the server. Ive tried sudo or maybe since the device isnt claimed im having issues.

The flashing sequence is rapid cyan with one red flash every once in awhile.

I dont mind sharing these:
My device ID: 5a0036000d51363034323832
My SIM ID: 8934076500002796563

Here is the log from the particle key doctor:

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Deducing device DFU version from functional descriptor length
Opening DFU capable USB device...
ID 2b04:d00a
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #1 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "DCT Flash   "
Downloading to address = 0x00000c22, size = 121
Download	[=========================] 100%          121 bytes
Download done.
File downloaded successfully
attempting to add a new public key for device 5a0036000d51363034323832
Error sending public key to server: Permission Denied
Make sure your device is in DFU mode (blinking yellow), and that your computer is online.
Error - undefined

Thank you!

Is your issue like this one I had? I have a video of what I was seeing as well, which should help to identify if your issues the the same

Photon Not Connecting to Cloud

The solution is in the post linked ot above as well.

Doing that on an unclaimed device might pose a problem.
We can ping @Dave to help out.

Thank you @ScruffR @shiv I tried your solution and that didnt seem to fix anything. I am on 0.6.1, @Dave any ideas? Thank you all!

You have an unusual problem where your device was not provisioned properly. Just create a support ticket and reference this post and we can get your device provisioning fixed.

The permission denied error when sending the key to the server most commonly occurs when it’s owned by another account, but in this case it’s because the device wasn’t provisioned. There’s no way to tell from the message which it is, however.


I provisioned that ID for you, try er now. :slight_smile: