Permission denied when updating firmeware?

particle flash DEVICE_ID system-part1-0.4.4-photon.bin

I get:
attempting to flash firmware to your device DEVICE_ID
Token error: Permission Denied

@pcproff, DEVICE_ID needs to be supplied by you. It is the name of your target device OR the ID number (multi-digit thing) associated with that device. So if you named your device “pcproff_1” then the command would be:

particle flash pcproff_1 system-part1-0.4.4-photon.bin


The numeric ID or people friendly name?

@pcproff, either!

Still get permission denied. DEVICE_ID was just a placeholder for my real DEVICEID in my original post.

@pcproff, I see. Perhaps your token may have expired and you may need to reset it via the web IDE or Particle CLI.

I am having issues handshaking with the cloud because during tinker setup I get “cannot verify device ownership” that is the only one that fails. Therefore, it showing up on IDE is not an option.

Actually, in case it is useful: I had exactly the same issue (Token error: permisssion denied when flashing) there this evening when trying to reactivate a long neglected Core.

I followed all the instructions etc. to use the particle-cli. nada.

However what did work was using dfu-util directly

  • Went to node npm installation direction
  • found the binaries which it wanted to use (in my case the deep_update_2014_06.bin binary
  • put core into DFU mode by holding down both buttons, releasing RST and releaseing MODE when flashing yellow
  • issued command dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave deep_update_2014_06.bin

… and this worked fine.

In general I find the particle-cli user hostile. There is no useful help either from the CLI itself or online. And the online docs don’t match the latest install. In this instance however some googling around suggested how to bypass it for DFU flashing …

Ha … I see that on the front page of the community it has these instructions for the Core as a backup to using particle-cli which is “easier”.

it might be easier but my evidence (admittedly based on a sample size of 2, 2 being the number of cores I tried to update) suggests that particle-cli no workee for flashing, not the slightest bit.

Note to the OP: the command to update the Photon is described here:
in the section on manual upgrade.

@pcproff can you do a particle logout and particle login again?

@liamf I was able to flash the board with this procedure thanks for that!!! But during tinker setup I cannot get past the “Verify device ownership” step and then I’m in rapid cyan blinking

Yes @kennethlimcp I was able to logout and login with no issues

Ok can you tell me what happens with particle list?

When in DFU mode and I try particle list I only get another photon that is offline not the one I am interacting with.

Ok so you are trying to update the system firmware right?

Place the Photon in DFU mode and do a particle update

I did the following particle update it restarted and now I am at blinking cyan with a hint of amber.

Ok cool that looks like bad keys to me.

Can you do:

  • particle keys new junk
  • particle keys send deviceID

@kennethlimcp You sir are DA MAN! You have got my photon up and running that was sitting in my electronics spare parts box for over two weeks! Thanks to all!!!

1 Like

Happy to help. Have fun :slight_smile: