Token error: Permission Denied

Hi Particles,
I’ve recently tried to flash firmware to my new Electron (really sped through orientation so might have missed something) and believe I’ve set it up correctly but when I attach to USB (Windows 7) and try to use the CLI – (which I’ve used plenty of times with Photons) I get the following …
C:\xxxx\xxxx\ELECTRON>particle flash --serial firmware.bin
Including: firmware.bin
attempting to flash firmware to your device --serial
Token error: Permission Denied
Can anyone advise what I’m doing wrong – or point me at the appropriate information on how to resolve?
Thanks in advance,

Give ‘particle login’ a shot?

Not sure what you mean. I definitely logged in before trying to flash. I have used the CLI before.

Maybe logout, revoke the current token and let particle login create a new one.

Your local CLI token might have gone stale.

Hi @ScruffR and @Moors7 ,It seems the problem is with the CLI, or rather my installation of it. I use a desktop PC for development but recently installed the CLI on a laptop - and using that platform the Electron worked and flashed code as advertised. I have since uninstalled and reinstalled the CLI on my desktop using the Windows installer and it seems we have a win. Thanks again to you both for responding.