Old photon particle-cli permission denied error


I have an old photon which I have not used in a while and I decided to give it a new function. So far so good, I got the photon connected, updated the tinker through the particle.io IDE and then I went on attempting to flash something from workbench.

Unfortunately I found that any particle-cli command sent to this specific device returns me a Permission Denied error message.

I tried to send some basic commands to the device (called pegasus :slight_smile: ) all returning me the same error:

particle flash pegasus tinker
Failed to flash pegasus: Permission Denied

particle nyan pegasus
Signaling failed: Permission Denied

I tried both MAC OS and Windows with exactly the same results, so I don’t think this is OS dependent.

I tried other particles I own and I do not get any error. Is there some kind of setting that prevent me from sending commands through the particle cli?

Just for context:

  • I just updated the CLI version (3.1.0)
  • My photon has the fw version 2.3.0

I am out of ideas, so any suggestion on how to address it are welcomed.

Have you tried particle login?

@ScruffR I did particle login and I can see the device as online.

particle list
pegasusPhoton [XXXXXXXXXXX] (Photon) is online
    int digitalread (String args)
    int digitalwrite (String args)
    int analogread (String args)
    int analogwrite (String args)
1 Like

Hmm, particle list lists the device as pegasusPhoton but in your original post you address it as pegasus only - that doesn’t match up :wink:

Ok… this is interesting. On the particle we console it showed up as pegasus. But it is true that when I do particle list it shows up as pegasusPhoton.
When I tried to flash the tinker with pegasusPhoton it worked…

particle flash pegasusPhoton tinker
attempting to flash firmware to your device pegasusPhoton
Flash device OK: Update started

Flash success!

I think I will un-claim and claim this device again just to see if this fixes the issue on the particle console…

Thank you!

1 Like

You should not unclaim and reclaim the device - this usually produces more problems than it solve.
You can just rename the device.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.