Photon only flashing tinker, used to work before [SOLVED]

Hi, I have tried to figure out the problem with other blog posts but I can’t find it.

My photon’s were shut down for a while due to DIY home improvement. When I tried to get them running again today, with a changed Wifi password in the meantime, I decided to remove them from my account and treat them as a new photon (blue blinking, add through the phone app). For one that worked perfectly, from Tinker I flashed to it’s app through Web IDE. The other one doesn’t want to flash new code. Every time I try to flash it gets back in Tinker again. It responds to commands, I can see it in Web IDE, I can signal it, but not flash it.

Have tried to go into DFU mode, particle update and particle flash --usb tinker, which has helped me in the past to solve errors (and SOS codes). No luck.

I tried to update CLI, but my Mac is complaining that I am not administrator, which in fact I am, so can’t update. Particle identify doesn’t work. Particle setup can’t find the connected particle in DFU mode.

Anyone having a clue on what is wrong here? thanks in advance for any help,


I can help with the CLI problem:

Remove any old installation. If you get a command not found error, just go to the next step.

sudo npm uninstall -g particle-cli


which particle

If it reports one in /usr/local/bin/particle, remove that. It should not return anything, however.

sudo rm /usr/local/bin/particle

Then install using the Particle CLI installer:

bash <( curl -sL )

There are additional instructions here if necessary:

1 Like

Removing a device from your account doesn’t do it any good. If anything, it’ll complicate matters.

What does, or doesn’t, that do? Is there a CLI output we can have a look at?

If asking nicely doesn’t work, “sudo” often does. Perhaps @nrobinson2000 can chime in on the OSX side of things(?)

Again, any CLI output for us to look at would be great. It’s as they say:“one command line output says more than a thousand 'it doesn’t work’s” :wink:
What state was the device in when you tried to identify it? It should be in listening mode. Particle setup should also be in listing mode, not DFU, if I’m not mistaken.

1 Like

Like @Moors7 said, you could try sudo.

I tend to install particle-cli my own way and not use the steps @rickkas7 suggested because they don’t work for me.

I always use po-util to set up my Particle environment. particle-cli is one of the tools it installs.

You can install po-util with:

bash <(curl -sL

Ok, I got it running!

what I did (maybe not all equally relevant after all…):
*update particle cli with ‘npm install’, but then with sudo added. That asked for my password so no more problems with write access denied.
*then it didn’t recognise my ‘particle …’ commands anymore; I think I might have been in the wrong directory in terminal, I am not that good with it
*went online to particle CLI install instructions and used this command: bash <( curl -sL )
*that installed a fresh version of CLI. After that it didn’t recognise my particle … commands (like before). Opening a new window in Terminal worked.
*I used ‘particle setup’, chose to not use the account it proposed but login again. Then it recognised my particle that was connected via USB and indeed blinking Blue.
*I setup Wifi and flashed the Blink a LED app. Still no luck, Photon remained in Tinker when checking in IOS app.
*Then did particle update through USB (with Photon in DFU mode, yellow blinking)
*Boom! My blue led started blinking. So: the app apparently was loaded before but it was not running for some reason. Then I flashed it with the code I wanted to put on, and that worked like before.

Problem solved! Thanks for the help!

Still, being a product design engineer, also working on UX; Isn’t it strange that it can be so hard to flash a Photon back to factory settings, like how it was when it came out of the box?

That very much sounds like you had an older version of system firmware running and we’re trying to flash a newer version of user firmware, which indeed doesn’t work. It’s then supposed to go into safe mode where it will try to “auto-heal” the system version to match the newer user version. Since it didn’t have a wifi connection, it wasn’t able to do that, and as such would stay ‘stuck’ in safe mode (breathing magenta).

Seeing as system firmware is being updated regularly, you’d be moving backwards if you were to try to get it back to an older factory version. More often than not, that creates more problems than it solves.
There really shouldn’t be a need to factory reset it, since safe mode should be able to get you out of most issues. If that fails, there’s always DFU which allows you to update both system and user firmware. That requires you’ve installed the Dev tools correctly though. Granted, that last bit could be made a bit simpler, but tools like po-util seem to be helping with this already :slight_smile: