Can't over-the-air flash

I've been away for quite some time, so I'm likely very out of date. I just tried to command line cloud flash an Argon running 2.1.0 with a new binary and I got the error "Failed to flash garageDoorChime: Permission Denied". I'm logged in as the correct user and updated the command line tool. I can see my device listed via particle list. Any suggestions would be welcome. I've missed working in this space and I'm eager to get re-acquainted.

@Support - can you take a look tomorrow?

By "take a look" do you mean trying again? If so, then yes. Thanks

was tagging in the support team :slight_smile:

Can you DM me the device ID (and your account email if it’s different from the forum) please?

Just to update any interested party and close this issue, I had evidently logged in so long ago the session was invalidated and I simply had to logout and login. Strange how so much functionality was available to me, but not flashing. Thanks @no1089 for the assist!


I assume this thread has not been solved. If it has been solved, please start a new topic. :grinning:

If you meant "not Cloud flashing" then yes, several things have changed which might be affecting your projects. Just yesterday, I tripped myself up by not following relatively new guidelines in using Workbench and CLI. Here are some posts with good explanations with what has changed and could be affecting you:
In my case, I was sending TOO MANY, or, irrelevant files to the cloud which caused an error. So, for every project I add to my workspace two files:

This ignore file allowed be to keep copies of libraries in my file structure and NOT use them for cloud compile or cloud flash to the cloud. (e.g. lib-old, lib-old2, lib 2, etc.)
Sometimes I make a change to a library I am using in my local workspace compared to the cloud release version. In those cases, I need to make a change to the file: so my local version of the library will be flashed instead of the cloud version.

The issue was solved early today as I mentioned in my previous post.

Sorry, I misunderstood. :blush:

No problem. I appreciate your intent to help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.