Particle IFTTT activation fails

I thought I’d try the IFTTT integration today: no luck. When I’m instructed to activate the Particle channel I’m redirected to the Particle site to authenticate. I enter my creds and I’m returned to the IFTTT site which just says that something went wrong. No details provided.

I have notified the team and hopefully it gets resolved asap.

Hey @mjmare,

Sorry about that! I was just able to reproduce and fix the issue, it was a problem with the renaming of our IFTTT channel and the OAuth setup. It should be working again now.


It is!!! Thank You!!

It is working. Thx!

Hi, it’s August 29 and I get the same error:, “not connected”.

Could you help?

I’ll look into this. The easiest way to fix it now should be to “Reconnect Channel”. Previously I fixed this by making the IFTTT refresh tokens last longer, but I’ve since learned the IFTTT api expects the refresh tokens to never expire.


Thanks Dave,

I was connecting the channel for the first time, and it worked after you’ve applied the fix.

All the best!

1 Like