Particle DEV not showing Device List?


#1

I’m trying to program a Photon using Particle DEV but I can not choose the target device I want to flash.

When I hit Device Icon it just sits like this forever:

I’ve restarted the app over and over and it never loads. Not sure if this is the same for everybody or just me. Maybe I need to update but I figured I would ask since it might be something that needs fixed on Particles end. I have never had this issue before, the Online build IDE is working just fine.


#2

Does particle list return quicker?


#3

DEV never loads device no matter how long you wait.

I deleted Particle DEV and I’m installing it again to see if that fixes it.

I’d rather not use CLI if I don’t have to since for me personally DEV is preferred over the CLI method of flashing.


#4

For some reason, I have been this error when opening Particle DEV.

Even with this error message I was still able to load my connected devices and flash them just fine.

I deleted, restarted, and then installed the latest Particle DEV download package and then installed it but nothing has changed.


#5

Yeah I got this, too. I assumed it was some customization option that I made, screwed up, and failed to remember doing.

Glad it’s not me.


#6

Solved it by logging out and back into my account from within DEV :wink:

I was logged into my account already and it always worked just fine so weird, just glad it’s working now!