Particle Dev not "Loading devices"


#1

Downloaded the latest Particle Dev (1.7.4), starts up, recognizes me as logged in. Ask to select devices and hangs with “Loading devices…” Worked fine with the previous version (1.0.19) I used yesterday. I have a bunch of ‘devices’. Help?


#2

Could you try logging out/in for good measure?


#3

first thing I tried :grinning:


#4

Try opening up the dev console, click the “console” tab, and then try selecting devices. What do you see in the console tab?


#5

Downloaded again and everything works fine.


#6

Same issue here, just Loading Devices...

It’s unfortunate the only way to fix this is by re-downloading. Can confirm this works.

My system is Windows 10 64-bit. Just upgraded from 1.7.3 to 1.7.4.


#7

I’m having the same problem. It was literally working an hour ago. I stepped away came back and now it doesn’t work.

What I did differently today:

  • I claimed a new device via the app.
  • I tried to edit a .ino project that was part of my github repository, but didn’t like how it looked so I exited the window… deciding to edit in a different folder then copy it over to my repository.

Going to uninstall and reinstall. Lame!


#8

Sorry for the previous post: now it seems to be working no uninstalled necessary.

What I did, though not sure what worked:

  1. I did restart the program several times and restart my whole computer. (I’ve got a mac book pro Sierra 10.12.4).
  2. I was also trying to select a device that was not physically connected to my laptop.
    –so I connected it, that didn’t work. I tried using the CLI particle list and got nothing
  3. Plugged in two other photon (physically to my machine: usb), still loading devices...
  4. posted the above
  5. opened particle dev again after closing it and now it works

I have no idea what happened, but thankfully no reinstall for now!!!


#9

Same issue for me today but I fixed it by logging out and then back in and that fixed it.

Figured I would post this for others.


#10

Worked for me too. :slight_smile: Thanks.