Particle Dev won't connect to my photon

Ok, I have my photon claimed and everything. And when I have it powered up and breathing cyan, the online IDE will recognize it. But unfortunately, it is not recognized in Particle Dev. And yes I am logged in and everything. This is a huge problem. Help is appreciated.

Do you happen to have other devices that it does recognise?
Could it be that you’ve made a typo when creating accounts and have accidentally logged in with the wrong one? (Try logging out of both the Web IDE and DEV, then log in to both with the same account again)
Have you tried setting up the device using the app (which will claim it for you)?
Does it show up in the app?

1 Like

Ok. So I tried logging out of both the accounts and logging back in. Nothing changed. And yes I claimed it with the app and it shows up online in the app. I had problems right when I upgraded to the new particle dev. But the problem was, I had to upgrade to the new Particle Dev because the program I am using (made by the company I work for) would not compile on the old particle dev. It does on the new particle dev but it can’t connect to any devices for some reason.

Would you be willing to reinstalling Dev, that might help.
Let’s call in @suda though, since he built it.

If you log in to unofficial web interface, do you see your Photon being online?

Yes. Yes I do see my photon being online in the unofficial web interface.

Also. I tried uninstalling Particle Dev then reinstalling it. It still does not work.

Hmmm could you post a screenshot of devices list in Dev? Also: you may try to remove ~/.particledev directory (%HOMEPATH%\.particledev on Windows)

Ok. I’ll do all that once I get to work later. I installed particle dev on my PC at home and it will recognize the photon under devices just fine.