Particle build page doesn't show the right firmware version

Hi,

I use ‘partcile update’ to update my device. And I get it’s firmware version is 0.5.3 now ( Why 0.5.3, the latest is 0.6.1, right?). But the particle build page still show 0.5.1.

And my code used to work fine. But now I cannot compile it successfully. The following error message is thrown:

Thanks.

Are you using the most recent CLI (currently 1.20.1)?

I upgraded particle-cli to the latest version. The firmware version of my device is 0.6.1 now. But it still shows 0.5.1 on the particle build page.

I removed that device and tried to add it back again. But I failed to do this

The device id is correct. And the light is correct. I don’t know why the device is not connected. I tried to do a factory reset with tinker, still no luck.

Unclaiming and reclaiming does hardly ever solve problems :wink:

What do you consider correct?
You can try Safe Mode for that too.

An easy workaround for your initial issue with the false report about the installed system is to flash a dummy sketch with the reported “on device version” OTA. This should force a refresh of the info in the cloud.

Safe Mode works now.

After reclaiming the device, the particle build page shows the correct version now.

I noticed that the project structure upgrade cause many problems. It works now after fix several issues.

Hi,

i have the same problem after upgrading to 0.6.1. when i putty into the device i see 0.6.1 reported (with the ‘v’), but the web ide still reports the old 0.5.3. My CLI is 1.20.1

Can you explain what " flash a dummy sketch with the reported “on device version” OTA" means. I am not sure what to do here…

thanks

Set the target version in Web IDE to 0.5.3 (as you said, that’s reported to be on your device) and flash this code

void setup() { }
void loop() { }

which doesn’t do anything, hence dummy

seemed to easy!

but, that fixed it. it now reports the correct version.

thanks!