Particle Argon - connecting to iphone hotspot

Particle Community - I teach an Internet of Things course and, once again, could use a little help for my students. We are using Argons, mostly in the classroom. However, for their capstone projects, I have a couple students that need to be connected outdoors. We are able to connect to an android hotspot no issue (particle serial wifi and enter the android credentials). However, it does not seem to work for connecting to iphones. Is there a tip or trick of what might be needed to connect Argon wifi to an IOS hotspot? Thanks.

Hi Rashap! It should work without an issue. Can you send a screenshot of your Wifi connection routine in the CLI?

There’s more information available here: https://support.particle.io/hc/articles/360052621274/.

Marek,

I appreciate your assistance. Things look fine on the CLI side.

image001.png

But, the devices stay in “flashing green” mode. When we try with an android phone, we get to “breathing cyan” without issue. We have tried a few different iphones and a few different argons. One of the argons that didn’t connect to an iphone, connected to android without issue.

Thanks

Brian

image002.png

Have you - by any chance - got access control switched on?
With that you need to white-list the device’s MAC address in order to have it join your hotspot.

1 Like

Another thing that occasionally causes problems is the default name of name’s iPhone has a typographical quote in it, which causes problems when you try to enter the SSID in the CLI using a regular apostrophe.

1 Like

Not having an iphone myself, I’m waiting for my students to get back to class to test the above suggestions. I will have them change the “name” of the phone to something simple (if it is not already) and get that “allow others to join” is enabled (https://support.apple.com/en-us/HT203302#wifi)

In addition, my experience with iPhone 6/7 plus, has been that if a wifi device sleeps, after a few minutes the iPhone will stop Internet sharing, so when the device wakes up again it can not connect again.

Thank you everyone. Using the above to make sure the iPhone was setup to accept connections and then clearing the wifi credentials followed by loading only the hotspot credentials seems to have worked. On behalf of my students, appreciate the help.

1 Like