Argon wifi credentials

For the last few hours I have been trying to get my Argon to connect to my iPhone hotspot. I have read many posts on possible solutions and believe I have tried most, if not all of them.

I even tried a new Argon right out of the box. While claiming the Argon via the app v 3.3.0 my iPhone hotspot is not listed so I must use my home WiFi to complete the claiming process. I have read @rickkas7 post that says the 's on the iPhone name could be a problem so I removed it. I have connected the Argon via USB and performed particle serial wifi as explained by @ScruffR .

Still no matter what I do, the only wifi it connects to is my home wifi. I have done a factory reset, unclaimed and reclaimed the device to no avail. Has anyone ever actually confirmed that they are connected to their iPhone hotspot?

Hopefully I just missed the post that solves it for me and someone points me to it. Thanks

An Argon can connect to an iPhone hotspot, I just verified that it works, but it’s tricky.

  • Enable maximum compatibility mode in the iPhone hotspot.
  • You cannot set the Wi-Fi credentials from the Particle mobile app.
  • You can only use the Particle CLI particle serial wifi command with the Argon connected by USB to a computer.
  • Scan for Wi-Fi networks will probably not work, answer n and enter the SSID manually.
  • Select WPA2 as the Security Type.
  • Select AES+TKIP as the Cipher.
  • Make sure the hotspot is activated either by having the Hotspot configuration open, or manually enabling it.

@rickkas7 Thanks for the reply.
Enable maximum compatibility-did that
Understood, I am setting them via a USB, issuing particle serial wifi and entering the SSID and Password
Scan for networks, tried both and sometimes it found it, sometimes it did not When it did find it, I chose the correct SSID
Selected WPA2 and even unsecured, neither seems to work
When using WPA2, I did choose AES+TKIP as noted by @ScruffR
Not sure what you mean by “make sure the hotspot is activated by having the Hotspot configuration open”? I was manually turning it on via the slider.

I should also mention that when I turn off the hotspot, the argon stays connected. Presumably to my home wifi connection which was used to claim the argon.

Thank you

If you have multiple credentials configured, it will connect to the one with the strongest signal, even if you just configured a new one.

When I tested this I held down the MODE button and tapped reset and held down MODE while the status LED blinked magenta (red & blue at the same time), yellow, then white, then released MODE.

Once I removed my real credentials, configured the hotspot, then it connected to the hotspot.

1 Like

@rickkas7 Thank you I will give that a try and report back

I should also note however, I took the argon for a ride in my vehicle where the only wifi present was the hotspot. Both devices disconnected by the end of the driveway. Is there not anyway to only provision with the hotspot credentials to avoid the possibility of the “strongest signal” issue and instead only give it one choice?

Thanks

This proved to be the difference. Thank you again @rickkas7