Argon not finding laptop wifi hotspot (but connects to local wifi network)

Hi -
My Argon connects to the local (home) wifi network with no issues. Initial wifi setup was done through the Particle phone app.

Now, I would like to connect the Argon to the laptop’s (Windows 10) wifi hotspot. Running particle serial wifi from CLI finds several SSIDs from adjacent houses, but not the laptop hotspot’s SSID. As a check, another laptop successfully connected to the hotspot with no issues. My phone sees the hotspot SSID as well.

Maybe this is a Windows encryption issue, but I didn’t think that would affect finding the hotspot SSID.

Any advice on what to try next? Thanks.

UPDATE: Thanks for the advice everyone. Issue resolved when using a different laptop running particle than the laptop hosting the hotspot. Also, using the MODE button seemed to put the device into listening mode better than particle usb start-listening (in my case at least).

I believe the problem is that the Particle CLI Wi-Fi scan in particle serial wifi actually runs on your laptop, not on the device. The laptop does not return its own hotspot, because it can’t connect to itself.

If you do not scan for Wi-Fi networks and instead manually enter the SSID it should work.

Another thing to consider may be the band the Laptop WiFi is using.
The other laptop and the phone probably can connect to 5GHz networks, the Argon cannot.

Particularly if your computer itself connects to a WiFi network which may only offer 2.4GHz that band is occupied by the “upstream” connection and cannot be used to for the “downstream” hotspot - at least that’s the case on my MS Surface devices and Lenovo Yoga.

1 Like

Thanks, the band is set to 2.4ghz.

Ok, that helped. I plugged the Argon into another laptop, and Argon did indeed find the SSID from the hotspot. I selected it, and then it throws an error. Ran particle usb start-listening to get the blinking blue, but same result when particle serial wifi was tried again. I should probably note that particle usb start-listening never terminates - it just flashes the sending command to device message. Ctrl-C to get out.

PS C:\Users\iotum> particle serial wifi
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: Gemini
! Something went wrong: Serial timed out while initially listening to device, please ensure device is in listening mode with particle usb start-listening
PS C:\Users\iotum> particle usb start-listening
▌ Sending a command to the device...
PS C:\Users\iotum>

Connected second laptop to mobile hotspot and verified that encryption is WPA2-Personal.

Hi, I often get errors with particle serial wifi.
I need to run it like 5-6 times for it to succeed.
Perhaps you can retry?
Best,
Gustavo.