Particle setup --wifi Argon

Anyone try to change your wifi network on an Argon via CLI yet? (particle setup --wifi)?

I have my Argon in setup mode (blinking blue). When I issue the command and confirm my username it just gives the PROTIPs and back to command line.

I’m having all kinds of issues with connectivity (I think there’s something up with Uverse router and this Argon), so trying to change Wifi over to my iPhone or verizon hotspot to see if things become responsive. But… I can’t :frowning:

Can you use the iPhone particle app to setup the Agon again with your phones hotspot?

Yes, I’ve done that a few times already tonight… was hoping to just use the CLI…

I’m lazy? maybe…

Should it work on the cli? yes…

I have not tried that.

@ScruffR or @peekay123 may have though.

FWIW I just put a Photon into setup mode and tried it on same PC, went right into the normal wifi setup routine. I wonder if there’s something going on with the windows driver for the Argon. I have already had to do the Zadig route for DFU mode, but that is working fine now.

FWIW #2: Reinstalled Windows CLI, checked all options - same result.

I get similar except I get a serial error Node.js

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\Joe’s\AppData\Roaming\npm-cache_logs\2018-11-27T01_44_29_

C:\Users\Joe’s\particle-cli>particle setup
Error loading command C:\Users\Joe’s\AppData\Roaming\npm\node_modules\particle-c
li\commands\SerialCommand.js Error: The module '\?\C:\Users\Joe’s\AppData\Roami
was compiled against a different Node.js version using
NODE_MODULE_VERSION 47. This version of Node.js requires
NODE_MODULE_VERSION 64. Please try re-compiling or re-installing
the module (for instance, using npm rebuild or npm install).
I tried both without success.

Maybe a node reinstall? What version you on? I just realized I’m still on 8.11.3 - I don’t think that would be the reason for my issue, but I’m out of date.

Feels like a USB driver issue not sharing an recognizable device identifier for Particle CLI, or CLI not being able to handle the Argon for all commands yet.

Guess wait and see if any updates come down the pipe on the CLI. I’ll have to try my work PC in the morning.

There is no need to go through the particle setup process in order to change the WiFi credentials.
The dedicated command would be (and always was) particle serial wifi.

However, with 0.8.0-rc.25 we also got back the w command for serial terminal use without CLI.

BTW, what versions CLI have you installed?
Also make sure that there is no other instance of CLI installed on your Windows machine.
To do that, uninstall CLI via control panel.
Then run npm uninstall -g particle-cli in case there was a previous version installed via npm.
Restart the computer and try running CLI. If you don’t get an error repeat npm uninstall -g particle-cli till you do.
After that reinstall CLI via the most recent Windows CLI installer and try again.

Current version should be 1.35.2