iPhone hotspot not visible in Particle App

Is there an issue with iPhone hotspots and the Particle App? I’m running iOS 15.2, and my Mac can see my hotspot, but the Particle App cannot. I was having problems connecting to our university’s wi-fi, so I told my students … watch this, tried to put in credentials for my iPhone’s hotspot … and they weren’t impressed :roll_eyes:

Hey, could it be that your hotspot is somehow configured to 5GHz?
Particle devices can only connect using 2.4GHz.


Hey Michael- I just tried a hotspot with my Argon and iphone and it connected seamlessly. It should connect as normal as long as all the permissions are correct. Were you using the mobile app for setup?

Yes. I’ve got Wi-Fi turned off, Personal Hot Spot enabled, with “Maximize Compatibility” turned on (which I think addresses Gustavo’s point about 2.4 GHz).

Hmm that is strange. How strong is your signal?

I’ve got 4 bars of LTE. I have the most recent version of the app, I tried rebooting, and I can connect to my hotspot from my computer. But on the app, where it says Your Argon is scanning for Wi-Fi networks to join, I never see my phone. I had read a discussion here making sure that the name doesn’t have an apostrophe in it, and it doesn’t. 'Tis a mystery (and I really could’ve used it yesterday during lab!).

Have you tried CLI?
Put the device into Listening Mode then run particle serial wifi.
When asked whether you want to auto-detect your network(s) decline the offer and enter your credentials manually.
You’ll probably also be asked for the encryption (WPA2 would be my choice) and the WLAN cipher (TKIP + AES should be a good choice).

1 Like

I have not, but when I do, well, initially I didn’t see it. But then I connected to my hotspot on my Mac, and now it’s visible there, thank you for (once again :grinning:) rescuing me.

It still isn’t visible on the app, though, I guess that’s a limitation?

1 Like

Correct. The iPhone Particle mobile app cannot see a Wi-Fi hotspot running on the phone that is running the app.

1 Like

@rickkas7 are there any reasons for exceptions to this rule? I was able to connect to my hotspot on the phone running the app.

Now that I think about it, you can’t see the hotspot running on the iPhone running the Particle app on the Photon. It might be different with the Argon because it may scan for networks differently than the Photon. The Photon actually does the Wi-Fi scan on the phone (or in the CLI), not on the device.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.