Photon2 cannot see my Eero network or iOS Wi-Fi hotspot

I just got my new Photon2 and am trying to add it to my Wi-Fi network. It can see my neighbors' Wi-Fi SSIDs just fine, but the Photon2 cannot see the Wi-Fi network from my home router (Eero Pro) or mobile phone (iPhone hotspot), so I can't get it online. I'm using pretty default settings on both networks so I don't expect an issue. Any ideas on how to debug why it can't see my SSIDs?

I've tried with both the internal antenna, and attaching the Particle external antenna as well.

Not sure if it is apples to apples, my P2 didn't see any networks. So, I used the command line. You may have to install it.

(I run linux so I had to change permissions on the /dev/ttyACM0 file. Your name could be different. )

I then did:

particle usb start-listening

answer was "Done"


particle serial wifi
? Which device did you mean? /dev/ttyACM0 - - undefined
? Should I scan for nearby Wi-Fi networks? Yes
? Uh oh, no networks found. Try again? No
? SSID wireless5
? Wi-Fi Password xxxxxxx
Done! Your device should now restart.
(I had to manually reset)

wireless5 is the name of the access point I connected to, enter manually.

1 Like

Can you try using Configure Wi-Fi | Tools | Particle?

@louyo that did it! Thanks for the suggestion! Worked exactly as you suggested. I'm on macOS and the serial automatically guessed correctly as the right device without the need to do the particle usb start-listening part. Interestingly, it did see my Wi-Fi network when running the scan, so I didn't have to manually type it in. And even after connecting the browser tools do not show my Wi-Fi, the CLI does. Luckily, it stores existing networks so I could complete the rest of the claiming process.

@no1089, the Wi-Fi configuration page had the same results as the Device Setup | Tools | Particle page did, and could not see my Wi-Fi network. I do have a mesh Wi-Fi network, and through the CLI, I saw multiple entries for my Wi-Fi SSID (one for each node in my mesh). I just picked the first of the multiple SSIDs shown on the CLI and it connected just fine. After that the rest of the provisioning process was fine.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.