Output not working

Im using macOS. When i flashed code in WEB IDE , it cant show output. How can i fixed it ? Please help me.

What output and how have you tried to show it?


I tried to potentiometer code in particle web ide. Code is correct but serial port screen does not work. There are 2 issues.

  1. Consele --> when i flashed code–> particle device update pending and forced result is false.
  2. In my terminal when i wrote particle list ; i can see my device but when i wrote particle serial list (result- no devices available serial list)
    You can look screenshot. Im really dont understand what is my device problem

What device OS version are you targeting?
Have you got a Serial.begin() call in setup()?
Is your device breathing cyan when you try to list it?

You should be able to use apps like CoolTerm too.
Or use MacOS’ own command to list connected devices ls /dev/tty.* and then use
particle serial monitor --port /dev/tty... --follow on the port you found.

Yes breathing cyan.

here, what u asked.
How can fix that ?

That tty.Bluetooth-Incoming-Port is obviously not the correct port as the Photon is not connecting via Bluetooth :wink:

You may want to try a different USB cable and port.
Also add some means of checking whether the device is actually running the code you intended.

e.g.

void setup() {
  pinMode(D7, OUTPUT);
  ...
}
void loop() {
  digitalWrite(D7, !digitalRead(D7));
  ...
}

With that you should see the D7 LED blink at your 10Hz rate.

I also just realized the port may be listed as /dev/cu.usb* too.

It is working when i write this code also i blink my rgb led. My macOS cant see in serial port. I dont understand that.

My device has not been used since 2016. After upgrading its target(DFU mode), it does not see in the usb port. Is it only because of the usb cable?

To reiterate the point of that statement: run ls /dev/cu.* and see what comes up this way.

Possible but not enough info to say for definite.

problem is usb cable :thinking: . I bought another usb cable and i saw in port.

1 Like