Serial Monitor in Particle Dev isn't working

Hi all!

This is my first time using the Particle Photon, and i have 2 copies with me :slight_smile:

I wanted to test out the serial monitor in the Particle Dev and so i applied a basic code as posted at the bottom of the post.

My port is detecting the photon but it is not connecting and there is a flash of blue outline at the “Enter string to send” field upon clicking connect.

I’ve tried with both Photons and i’m unsure if there is something I am not doing right.

This is my code:

void setup() 
{
    Serial.begin(9600);
    Serial.println("Serial Begin");

}

void loop()
 {
int x;

x++;
Serial.print("x= ");
Serial.print(x);


}

What OS are you on?

I am on Windows 10

Can you connect with another serial terminal like PuTTY?
Does adding some delay(100) in loop() change anything?
Is the COM port selected in Dev the one your Photon got assigned in DevMgr?

I added but it didn’t change anything

Yep, both assigned to COM5

(I have also tried using other wires just in case)

I am still learning how to use this now, will get back ASAP

@ScruffR @Arunn I had this same issue when I upgraded Photons to firmware 0.6.0 where the serial monitor app would not work in Particle Dev anymore. It would work with TeraTerm Terminal app though.

Here is what I did to get serial monitor working in Particle Dev again

1 Like

It works with PuTTY! Thank you so much for the help!

So does that mean i wouldn’t be able to use Dev? (Just asking :relaxed:)

1 Like

@RWB I see! Okay, i shall give it a try :grin: Thanks!

1 Like

Can you explain how PuTTY works? I’m having the same issue as Arunn.

I also installed the latest version of Particle DEV on a new Macbook running Windows 10.

The serial monitor in Dev will not work but TeraTerm serial does work.

Last time I had to use Zadig to change the Particle device driver to get the serial monitor in DEV working again. I think I posted this in an early post in this thread.

Currently I just use TeraTerm for serial monitoring since it provides lots of fexibility.

There is not a lot to explain.
Select Serial interface, set your COM port and hit Open

2 Likes

I cant see anything in serial port!
even when I use PuTTY :confused:

I found that after Updating the Photon to firmware 0.6.1 the serial monitor in Particle Dev works now when before I needed to run Putty to see the serial output.

I have the same problem, serial monitor is not working in the Particle Desktop IDE, so I need to use Putty or simply the serial monitor in Arduino (I checked, photon is working with both but I would like to use the on Particel Desktop IDE).

I am using Windows 10, Photon firmware 0.6.3 and Particle Desktop 1.19.0

Did anyone find a solution?

wow… still no fix :frowning:

@marcusone, the Particle team is focusing on the new Particle Workbench which is intended to replace Dev.

1 Like