[resolved] Serial debug not longer working on 0.6.0 or 0.6.1rc

Hi there.
I recently build two new devices and it was impossible to use the serial connection. The Atom IDE serial monitor never connects to the Photon. I tested 2 different computers with same results.
Strange enough a Photon with 0.5.2 firmware worked perfectly, when I loaded the same code and the system firmware was updated, the serial stopped working again.

I read all the documentation but it seems that nothing mayor has changed. I already use the blue LED to signal the moment to connect the serial monitor.

The line in the docs: while(!Serial.isConnected()) Particle.process(); didn’t make a difference.

I tried for 5 hours now and I’m very frustrated. Not clue what’s wrong.
Please help me. Thank you!

void setup() {




void loop() {


Can you try a different serial terminal program?
What OS are you running?

I cannot use neither the serial comm on Particle ide. I use termite, xshell or arduino ide instead. Give them a try.

My 0.6.1-rc.1 devices work fine, so there must be something on your side.

Again, what OS?

Hi @ScruffR. Sorry for the delay.
Windows 10 tested, Windows 7 and Mac OSx Capitan. All of them fully updated.

What finally worked for me (a few minutes ago)
I used dfu-util and flashed FW 0.5.2.
I tried my FW (from the web IDE and keep 0.5.2) and still not working.
I then flashed my FW from Atom, platform was updated to 0.6.0.
And it started to work…same FW, same computer, same USB cable, same port, I didn’t even rebooted
the computer.

Thank you.

Can we mark this a resolved then?

If there’s not a reasonable explanation…I guess that it’s solved.