New Photon, can't add device in web IDE


#1

I jsut got my replacement Photon from Particle. I was able to add it to my LAN using the Particle app easily enough. Then I went to the Web IDE. I clicked on “Add new device”, pasted in the device ID I got from the Particle app. Then it went

This device is already owned by a different user. Would you like to request a transfer of ownership?

So I said Yes and it went

Could not request transfer.

Now what??? And please don’t tell me I need to use the particle cli to fix this because after updating it from 1.16 to 1.20, it doesn’t work anymore.


#2

@Dave can you check on the backend with the device ID?


#3

Check on the backend? Of what? (You get the world’s record for speediest reply!)


#4

I asked if the engineer at Particle can help you check on the backend what’s causing the transfer to fail and how we can have it added to your account…

If you have the CLI you can use particle device add DEVICE_ID to add the device you found using particle serial identify in Listening mode.


#5

Ah! OK. Thanks! FWIW, it’s pulsing cyan and if I power-cycle it, it reconnects fine.


#6

It needs to be breathing cyan for claiming to work. Did you try the steps above and see if it works?


#7

Well I do have the CLI on my laptop, the one where it worked fine under version 1.16. But after upgrding it to 1.20, it no longer gives me the “da ding”: USB device inserted sound when I plug in the Photon. I tried it in in my desktop PC which also has 1.20. On that one it does recognize the device, but the Found New Hardware Wizard just searches for a device forever without finding anything. So I’m stuck.


#8

You can grab the drivers here and see if you can install successfully: https://docs.particle.io/guide/getting-started/connect/photon/#installing-the-particle-driver


#9

OK - drivers updated. This is what I get from the CLI:

C:\Documents and Settings\Owner>particle serial identify

Your device id is xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Your system firmware version is 0.5.3

C:\Documents and Settings\Owner>particle device add xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Claiming device xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

! Please login - it appears your access token may have expired

Failed to claim device, server said: Invalid token

C:\Documents and Settings\Owner>

#10

great! Simply do a particle login followed by particle device add DEVICE_ID


#11
C:\Documents and Settings\Owner>particle login
? Please enter your email address xxx.com
? Please enter your password **********
> Successfully completed login!

C:\Documents and Settings\Owner>

OK, so I rebooted the Photon (it’s pulsing cyan), went back to the web IDE, tried Add New Device again, and got the same error message as in the OP.


#12

Is the device still pulsing cyan or breathing cyan?


#13

OK, well I call it “pulsing”. It’s not alive so it can’t breathe. It’s in the usual state it’s in when all is working well. In my last post the copy & paste missed the second half:

C:\Documents and Settings\Owner>particle device add xxxxxxxxxxxxxxxxxxxxxxxxxxx
Claiming device xxxxxxxxxxxxxxxxxxxxxxxxxxx
? That device belongs to someone else. Would you like to request a transfer? Ye
s
Failed to claim device, server said: This device is owned by you

C:\Documents and Settings\Owner>

But when I try to add it in the web IDE, it won’t do it. Owned by someone else, that being me??? I’m starting to feel schizophrenic.


#14

That’s what i was guessing. The device is already claimed under your account.

I am guessing your photon RGB pattern looks like this: https://docs.particle.io/faq/particle-devices/led-troubleshooting/photon/#blinking-cyan

Can you place it in DFU mode and do a particle keys server?

It should connect properly with: https://docs.particle.io/guide/getting-started/modes/photon/#connected

To verify, you can do a particle list and see that the device id is listed in your account. (which means you don’t need to claim it anymore)


#15

No - it slowly fades from zero to full cyan, stays there for a while, then slowly fades back to zero, repeat.

I got it to blink yellow but now it says “dfu-util is not installed”. I’ve been down that road before and it’s a major pain. And I’ve got to run. I’ll try that later. Thanks VERY much though for the amazing real-time interaction.

When I do a particle list it says that this Photon (giving it its proper name and device ID) is online. It’s just the web IDE that won’t connect to it, meaning I can’t flash my code to it.


#16

@Michele, it sounds like your device is actually connected to the cloud fine.

Can you look in the Devices tab in the Web IDE and make sure you :star: that particular device? Otherwise, you are not targettng the correct device for OTA firmware flashing.


#17

Heya @kennethlimcp,

Thanks for the ping! Happy to check on whatever if it still needs checking, let me know. :slight_smile:

Thanks,
David


#18

Oh duh. There’s a big huge menu button on that page in the IDE called “Add Device” and since my new Photon wasn’t on the list that’s what I was clicking on. I didn’t notice the tiny two arrows in a circle icon to the right of Particle Devices on top of the page.

I just clicked on that and my new Photon suddenly appeared in my list of devices. I was then able to Star it so it appears we’re now good to go. I’ll mark this Solved. Thanks!


#19

Do you have a screenshot? That’s something that might be improved on.


#20

It just seemed to me that if you’re adding a new device, the big yellow button marked “Add New Device” might be the thing to click on. But apparently not.