New Photon not added to my account

Was using CLI to added new Photon, the add failed when Using particle setup (it did show a name) but would not setup wifi.

Searched the community, found that I should use particle serial wifi, set the SSID, Security and Password.

Photon rgb shows breathing cyan (believed to be connected to my wifi).

The Photon does not show on dashboard, under devices in Dev or particle list.

Tried to flash with tinker using the named that was shown when I attempted using particle setup, which gave me an access token link.<redacted-access_token>

Opened the link which gave me:

  "ok": false,
  "error": "Not Found",
  "device_name": "turkey turtle puppy lawyer normal"

Logged into my account using particle login, entered user email and password.

Tried to claim the Photon using particle device add <redacted-access_token>:
got back Failed to claim device, server said [object object]

Any suggestion?

The parameter to particle device add is a device ID, not an access token. You can get the device ID by putting the Photon into listening mode by holding down SETUP until the LED blinks blue, then issue the particle identify command from the CLI.

Reset the Photon and wait for it to breathe cyan before issuing the particle device add <deviceid> command because the Photon must be online for it to complete.

1 Like

I redacted your acces tokens out, since they would allow others to interfere with your devices.
Keep your access tokens private!

Thanks rickkas7, It worked great, it has been added.
Thanks ScruffR, I started not to add the access token, but want to be complete on what I had done. Will also change the access token, I think that I can from the build IDE.

1 Like

Well maybe I can’t change the access token, at least not where I thought that I could. Back to reading…

You can refresh your access token by clicking on the “Settings” icon at the bottom of the lefthand navigation pane and then clicking the blue REFRESH TOKEN button.

That should do the trick!