Multiple WiFi of same name, but different mac addresses

Hi all,

I have the spark-core connecting when I stand by the 2c:b0:5d:9f:87:a0 wifi, but cannot get it to connect reliably to the 14:d6:4d:ec:40:70 when I stand near it - both have the same SSID name.

See image for the WiFi layout in the office here.

I have had it connect a few times on the ~40:70 wifi, but it seems highly erratic. Wheras on the other one it seems fine. Because the WiFi’s share the same name, I wonder if that causes ‘issues’.

Sometimes it appears to go through the motions (following a 3 second mode press to clear wifi credentials temporarily) and gets to flashing green, but never breathes cyan.

The sequence of events listed below leads me to belive that perhaps the core is using the wrong mac address or something - I am really new to the whole wifi / mac address scene - so cut me some slack here :blush:

  1. Start near ~:40:70 wifi
  2. Press mode for 10+ seconds until blue rapid then release.
  3. Blue flashing.
  4. Run spark app.
  5. Select ‘Eden Free Wifi’ network on app, and hit connect, (unsecured, no pwd).
  6. Blue solid.
  7. Green flashing - for ages (5+ min)
  8. Take unit near to ~:a7:80 wifi instead
  9. Quickly connects and breathes cyan

Any suggestions or ‘try-outs’ would be greatly appreciated. Thank you. :smiley:


Are you using one of the two as WiFi repeater that picks up the WiFi and just resends the packets, or are both connected by wire?

For the latter setup, try assigning different channels for the two routers.

I have the same problem. My two routers are on 6 and 11 channels. Spark core can connect to only one which it connected first time.


Thanks for the replies. :smiley:

Both WiFi routers are connected by cable to a common switch/router.

I have narrowed down the problem to a RF issue. One unit is clearly more powerful than the other - on the D-link one, I need to be less than 5 feet away, but on the Netgear one, it works fine at 10-15 ft.

If I’m right next to the Dlink, it will connect and breath, as I walk to the Netgear, it will disconnect and flash green, and when I’m right next to the Netgear it will again connect. (No reset required in between).

So the summary of this is:

WiFi network consisting of 2 WiFi unsecured access points setup with the same SSID connected to the same internet router/switch by cable.

Spark core behaviour when programmed with SSID:
Connects to each without issue so long as signal strength is sufficient.

There must be a way to improve the range ?!?!

  • I can see that I’m going to need to also have a wifi booster in the same enclosure as the spark if I wan’t to log data in our environment!


Have you considered using an uFL antenna?
These usually give you better signal strenght than a chip antenna and you can move them around inside your enclosure or even put it on the outside.

Hi ScruffR,

Yes - this is with uFL antenna - in have tried several antennas:
A short -5dbi one off eBay, one from a D-link wireless router, and a 16dbi Yagi. All behave poorly, but the Yagi is somewhat better.

I have a NETGEAR PR2000-100EUS Trek Universal N300 Wi-Fi Range Extender on order - which I hope the core will be able to communicate with.

Intention is to site the extender so as to give a strong enough signal for the core to use; the PR2000 being able to relay -65dbm WiFi signal levels effectively.


1 Like

Just for reference - this worked beautifully.

Netgear PR2000-100EUS Trek Universal N300 connecting to existing WiFi network with -67dbm signal strength too poor to connect core directly.
Spark core comms set to Netgear PR2000 SSID, now has -30dbm signal and connects without trouble being only a foot away!

:slight_smile: :slight_smile:

1 Like