Problem connecting a new spark core to iMac shared internet connection wifi

Hello all, I am a newbie here. Just got my spark core. I have problem connecting it to the wifi and wondering if anyone here has any pointers for me.

It’s basically the forever blinking green problem, with a little twist which is, it happens only with WPA2 security. It can connect fine if I change my wifi to be an unsecured network (which is not ideal obviously)

I am on OSX 10.9.5, Wifi network is shared through internet sharing from the iMac. I tried channel 1, 2 and 11. And with all of them, I can connect if there is no password and can’t connect when there is one. Security type of an Internet sharing wifi on OSX 10.9.5 can only either be None or WPA2, but just to try different things, I tried using WPA in the wifi credential as well, but that doesn’t help.

I have tried setting up the connection using iPhone as well as through the USB interface (with “screen”) All the same - works when the wifi has no password and doesn’t work when there is one.

I have also tried updating the firmware of the CC3000 according to the instructions I found in the docs, i.e. using dfu-util and spark-cli, etc. Not helping either. Also tried repeating all the above after resetting firmware to factory settings. No luck either.

Any one has any suspicion on what it could be, if it can only connect without a password? Any pointers greatly appreciated. Otherwise, next step I am going to get a proper wifi router to try it out. Or the other direction (somewhat shooting darts in the dark :slight_smile: - could it be related to the AES key?

Thanks in advance everyone!


Have you checked shorter WPA2 passwords or have you got any “funny” characters in your pwd?

Can you connect other (none Apple ;-)) devices to your AP with the same settings?

Good advice from @ScruffR above but I have one more thing to try:

If this in Apple brand router, try temporarily turning off the 5GHz band. The Apple routers try very aggressively to move all traffic to the upper band.

1 Like

@bko, nice thought :+1:

But since I really don’t know, would having the network open (unsecured) not also fail then, or do Apple devices only force secured WiFi into the higher band?

This is a great question and I do not know the answer. I was just suggesting something that has helped others.

1 Like

Another - rather unlikely - thought:
Is your AP using WPA2 Personal and not WPA2 Enterprise? The latter one is not supported on the Core.

Thanks a lot for the replies, bko and Scruff.

@ScruffR - the password is 8 character long which seems to be the minimum required by the internet sharing on my iMac (osx 10.9.5) and no funny characters. I can connect to the wifi with iPhone (Apple device though :slight_smile: and Kindle (non-apple device) It says WPA2 Personal.

@bko - this is not a router actually. It’s a wifi created by the iMac sharing its internet connection through wifi. So maybe something funny is with this kind of configuration.

Let me get hold of a more “proper” “external” router like you guys suggested and revert back if I find anything.

Thanks again for the response!

Hi all, just to revert back with some findings. The problem seems to be due to the shared internet connection by the iMac. I have tried a different board called Wido which is an Arduino variation with a CC3000 chip. It exhibits the exact same problem. Connection works when the wifi network is without a password but doesn’t when there is a password. Log shows that it might have actually connected to the wifi, but it stalls on the DHCP request or rather, waiting for the DHCP response.

So although by no means conclusive, I suspect there is some incompatibility issue between CC3000 and the iMac shared wifi connection.

Using an external router, e.g. Airport express solves the problem (on both the Spark Core and the Wido board)

For now, I am going to just happily move on to the fun part of spark core programming instead of dwelling on this problem. But if anyone has ideas on what else to try, please do feel free to let me know, I would be very happy to try it out.

Thanks again everyone!