Just connected photon, unable to upload code

So I just unboxed a particle photon, used the app to initialize it.

It added to the cloud ide, and shows “breathing cyan” on the photon, and the ide.

I can get it to ident itself. (flashing rgb).

I can’t upload code to it (times out).

The app doesn’t recognize it as online (it says to reconnect…at the exact same time that the web ide says its connected and I can make it ident).

Any ideas?

Can you try Safe Mode?
What system version have you selected for your build/flash? (try a different one)
What code are you trying to flash?

I’m trying to flash blink. I guess I’m not certain which system version I’ve selected, and I’m not sure how to reselect.

I tried safe mode, no change.

Here you find how to select your device and also how to select the system version to target

tried every target, no joy.

Can you post a screenshot of your full Web IDE window with the target drawer open?

You may want to install CLI and do a firmware update via USB.
After that you may have more luck.

1 Like

yessir, you were correct.

I have a couple of these, and were all exhibiting similar behavior. Firmware update made everything work.

Thanks for your patience and time.


Thanks for the help @ScruffR!