[SOLVED]Particle Dev flashes code but crashes?

Tried to look this up but didn’t find much. I’m currently working with my 3rd Photon. I just uploaded some sample code through the Web IDE and it flashes and works fine. But the same code I’m trying to upload with Particle Dev, it starts to blink magenta and blue( as it’s being flashed) and then it goes into solid white. I made sure I had the right device selected and firmware up to date.

Has any one experienced something similar to this?


What does your code look like?
What target firmware version have you got set on Web IDE?

1 Like

@ScruffR the code looks like:

void setup() {    

void loop() {
 String name = "";
 name += "{ 'Blab' : ";
 name += " 'This' }";

I’m not using SEMI_AUTOMATIC or MANUAL, just enabling SYSTEM_THREAD so the code runs without being connected to WiFI.

I’m targeting 0.4.7 in the Web IDE

I also tested this code with another photon and it works. It’s that Photon in particular that doesn’t like the IDE so that’s frustrating. But it likes the Wed IDE. I wonder if I’m missing something to install or is the actual firmware?

I set it to DFU mode, did a sudo particle update and after the first time I flashed it; it stayed on the white light for a long time but it eventually got flashed. It works now!

1 Like