[issue] Fatal: not a git repository (or any of the parent directories): .git

I’m getting this error when compiling after creating a new workspace/project. It appears to compile correctly however.

I’ve tried the solutions suggested here:

and here:

to no avail. Any further suggestions welcome.

I’ve been getting this same error just recently. When I restarted Visual Studio code today there were some updates that took place. I’m wondering if those have something to do with these issues that are arising.

sorry about that. they’ve been there all along but we dialed back the logging and now they stand out. it’s a non-issue. devices os v1 introduces a fix.

When can we expect os v 1.0 by the way?

deviceOS@1.0.1 is available now - run the Particle: Configure Workspace for Device command or click the device os entry in the status bar

1 Like

Thanks…looking forward to the changelog as well :slight_smile:

@m_m That doesn’t appear to support gen 3 mesh devices, or?

This does

found via hitting either of these buttons in the above link
image

I’m still seeing 0.9.0 there…am I missing something?

EDIT: To clarify, I’m wondering when a fix will be released for this “git repository” error being spawned in Particle Workbench.

2 Likes

I’m also seeing this error every time I try to compile:

fatal: Not a git repository (or any of the parent directories): .git

When I do the Cloud flash it seems to work.

As clarified earlier, that git warning is a non-error and does not affect the compile process.