[ISSUE] Failed to launch OpenOCD GDB Server: Timeout


#1

hey all :wave:

it seems the extension we depend on to drive debugging - cortex-debug - released an update this morning that broke our integration (details here). if you are using v0.2.4 of the Cortext Debug (one of Particle Workbench’s extension dependencies), debugging will not work.

38%20AM

we’ll be working to get a fix out ASAP but in the meantime, the work-around is to use VSCode’s “Install Another Version” option to revert the “Cortex Debug” extension back to v0.2.3:

  1. From VSCode’s main menu select “View > Extensions”

  2. Disable automatic extension updates: Click the three-dot menu (...) in the middle column and select “Disable Auto Updating Extensions”

  1. Find the “Cortext Debug” extension: Click the three-dot menu (...), select “Show Installed Extensions”

  2. Install the 0.2.3 version of cortex-debug: Click the GEAR icon next to the “Cortex Debug” entry, click “Install Another Version”, and select 0.2.3 in the picker menu that launches

hope it helps - apologies for the bumps :pray::+1:


Help needed with development problems
[ISSUE] Particle Debugger Configuration missing
Particle Boron New Haven OLED Display Issue
Local Flash and Debugger hang in Workbench (VS Code) Windows 10
pinned #2

#3

as of Workbench v1.5.0, this should be resolved - if you’ve disabled automatic updates for extensions, go ahead and re-enable them and you should see the update download and install :+1:


#4

@m_m I have the same issue :open_mouth:
Workbench 1.5.0
Cortex-Debug 0.3.1

Any hints?


#5

:thinking: hm. well, that’s no fun.

it’s working over here (though i realize that’s not super-helpful) so i don’t think you are hitting the original issue captured in this thread.

regardless, let’s see if we can get you back on track.

first, generate an audit report: run the Particle: Audit Environment command (docs)

go ahead share the non-sensitive portions of that report here.

next, are you able to successfully run the local compiler (docs)? from VSCode’s main menu, select “Terminal > Run Task…” then pick the Particle: Compile application & DeviceOS (local) task from the list presented.

then, are you able to successfully flash using the local compiler? again from VSCode’s main menu, select: “Terminal > Run Task…” and pick Particle: Flash application & DeviceOS (local) from the list presented.

now, let’s clean all the things - “Terminal > Run Task…” then pick Particle: Clean application & DeviceOS (local)

assuming all of that works, let’s run through the debugging steps for your Particle device:

photon, electron, p1

OR

argon, boron, xenon, bsom

at which point does your error appear?

things to double-check: your device is connected via USB, your USB cable is known-good, the environment audit report shows ok: true across the board.