[ISSUE] Particle Debugger Configuration missing

I’ve only tried this with a xenon board so far, but I am not getting a debugger configuration when I configure my project for my device. Nor does the dropdown let me create one for Particle devices. I have tried it on my win7 and win10 laptops.

I now have a launch.json file that works for me from a coworker, but I wanted to post that I had seen the issue and couldn’t find any info on why the configuration might be missing.

a customized launch.json is created within your project’s ./.vscode directory when you run the Particle: Create Project command. did that not happen for some reason?

alternatively, you can manually create it if your Particle project does not already have a launch.json file by selecting the cortext-debug option from the configuration list (assuming your Particle project is open)

(click the gear icon in debug bar labeled “2” in the above image)

that all said, last i checked debugging wasn’t in a great state - see here:

i’m still digging out here after some recent traveling so i haven’t looped back on it yet.

edit: if you haven’t already seen them, check out our debugging docs here:

https://docs.particle.io/tutorials/developer-tools/workbench/#debugging-3rd-generation-

1 Like

Well, didn’t hit Create Project because I cloned the project from our repository. That might explain a thing or two.

#2 in your screenshot is what I was talking about being missing. One does show up after I got a launch.json from a coworker, but apparently cloning, then configuring your workspace doesn’t create that file on its own.

Good to know about other potential issues. Thank you.

I cloned the project from our repository

ah, ok. there’s been some understandable confusion around what files should be kept in source control and which files should not. we’ll make this easier soon but in the meantime, here’s the info:

additionally, while opinions differ i would check in the launch.json and settings.json files within your project’s .vscode directory - at the least in their initial states after running Particle: Create Project and ignoring changes after that. just be aware that .vscode directory usage is somewhat up in the air at the moment and occasionally you’ll find extension authors breaking certain assumptions - example. whitelisting specific files makes things a bit less risky.

One does show up after I got a launch.json from a coworker

for future reference, try moving that out of the .vscode directory and following the steps i shared above - you should see a new launch.json file be created with our configs :+1: