IOS Particle app crashes in Inspect mode


#1

When I launch the particle app on my iPhone and select the Inspect option it displays for a second and then exits the app. This had been working up to last Friday. I have 3 electron devices and they all behave the same way.
Regards


#2

+1
Exactly same symptoms.
I have 6 electrons.


#3

iOS version?
iDevice model?
App version?

More information is never a bad thing.


#4

IOS 10.2.1
Electron
Unable to get version number from application store but I removed app and downloaded again


#5

I didn’t know Apple made Electrons :wink: I was hoping for an iPhone/iPad version :stuck_out_tongue:


#6

iPhone 5s and IPad Pro


#7

Will look into it. Thanks for reporting!


#8

IOS 10.2.1 iPhone 5
Latest Particle app


#9

@ido, any updates? Have you been able to recreate the problem?


#10

Yep, I did. Working on it…
Sorry Apple keeps on rolling out updates that breaks code in apps.


#11

Excellent.
How about the android app, not sure if you are involved with it as well.
Are there plans to provide similar functionality?


#12

same symptoms iOS 10.2.1 iphone 7. I can see the screen and then the app vanishes into the background i.e. I can bring up the app by double clicking the home button but can’t stay on the Inspect screen. One more point, the action I can see on the Inspect screen before it vanishes is “Data usage Updating…”


#13

Thanks for the patch. The data option on inspect is extremely useful to me. I have 2 Electrons that are monitoring house temperatures 1500 miles from me at the present time and being able to to status them from my Iphone is so much easier than firing up a browser!
Regards,
Dan


#14

Hey guys, iOS app was fixed and re-uploaded to the app store. V2.2 should be available now and fixes the crash, thanks for reporting and for your patience.


#15

Sorry but this is still an issue. I had a new photon in Oct 2016 and could not set up WiFi on it from the IOS app (iPhone 6 running IOS 9) - the app just crashed as soon as it detected the device. Curiously, after managing to configure it for the first time with a different mobile, the app on my phone would no longer crashed and worked OK.

Anyway, got another brand new Photon, and V2.2 of the IOS app and it’s crashing in exactly the same manner when trying to set up WiFi on the photon for the first time - failing on two different iPhones (iPhone 6, IOS 10.2.1 and an iPhone 6S running the same IOS version).


#16

I have this issue as well:
v2.2
iOS 10.2.1 (iPhone 5C).

Steps:

  • I connect to my Photon-XXXX network in my Settings
  • I open the Particle app
  • I skip authentication (continue Yes)
  • I press the +
  • Select Photon
  • Ready
  • The wheel spins next to Photon-XXXX and then the app closes itself.

#17

Not a fix but the support team suggested the following workaround which worked for me while they try and figure out what is wrong with the IOS app. I’m sure they won’t mind me re-posting this here:

Would it be possible to set up your Photon using a computer instead? You’ll need to have the Particle Command Line Interface (CLI) installed, so if you have not installed it yet, follow the instructions here:

https://docs.particle.io/guide/tools-and-features/cli/photon/

if you are using Windows, make sure you use the Windows CLI Installer link and skip the other steps.

Put the Photon into Listening mode (blinking blue) by holding down SETUP until it blinks blue if it is not already blinking blue. Then issue the CLI command:

particle identify
Save the Device ID; you’ll need it later.

Now enter the command:

particle serial wifi
This will allow you to configure your Wi-Fi network.

If your network uses WEP Authentication you should follow the instructions on the linked page.

Reset the Photon. The main status LED should proceed through white, blinking green, blinking cyan (light blue), fast blinking cyan, to breathing cyan. If it does not get all of the way through, include that information in your reply along with copying and pasting the command prompt output. Also, if you get any other colors after fast blinking cyan, including red or orange blinks, let me know.

Only if you get all the way to breathing cyan:

particle device add YOUR_DEVICE_ID
Now you should be fully up and running and you should be able to see your device at https://build.particle.io.


#18

Thanks. Although I just wanted to share the bug. I’m aware (and using) the other possibilities to setup the Photon.


#19

Is this still an issue ?