[Solved]- Particle Android app crashing

Mod Edit (@harrisonhjones): Reduced title length. Original title: Particle app crashes on "verifying your credentials", then immediately crashes on startup every time afterwards

UPDATE: Solved - See bottom of this thread or here: [Solved]- Particle Android app crashing

I had the particle app working with my particle when I first got it at home. I was able to control the D7 LED with the android app and everything. Then we went to another house, and we tried pressing the “setup” button for 3 seconds to clear the wifi info to pair it to the other house’s wifi. But as soon as it hits “verifying your credentials”, the Particle app on the android crashes. And then if you try to open the app again, it crashes immediately on startup. The entire app has to be wiped or uninstalled if you ever want to launch it again. We actually tried 3 different Android phones, some on Lollipop some on Marshmallow, and it does this on all of them, so it clearly has nothing to do with the phone.

Even though the Android app crashes, it does successfully change the particle to the new wifi. Even though I can’t run the android app anymore, the particle is sitting here calmly glowing cyan, and I can program it from the web IDE just fine. I’m back in my original home now, and I was able to pair it back to my original wifi, but again, the android app is constantly crashing now. First I wipe the app data so I can get it to work again. Then I wipe the Particle’s data (I have tried pressing the setup button for 3 seconds, and doing the thing where you hold it for 10 seconds to wipe EVERYTHING, and the android app still crashes no matter what you do). Then I sign into the Particle app on the Android, and add a new Particle while it is in flashing blue mode. It finds the particle, for some reason it tells me “This particle is originally registered to moeburn@gmail.com, would you like to change owner?” even though I am currently logged in to the app using that exact email and account. So I tap “change owner”. I tell it which wifi to use, I enter in my wifi’s password, everything seems to be going fine, I get a few checkmarks on the app screen, and then right at the bottom of the list where it says “Verifying your credentials…”, the app crashes. Then if I try to restart the app, it crashes immediately on startup, and it will continue to crash on startup until you wipe the app’s data or reinstall it.

I feel like I’ve tried every troubleshooting idea I can think of on my end. You guys got any ideas? This WAS working for a few minutes at first!

Not actually addressing your problem, but a clarification

To clear the credentials you’d hold SETUP for 10+ seconds. 3sec only enters Listening Mode.

Yep, like I said, I also tried the 10 second reset where the blue light starts flashing really fast. Then I reset the Particle app data so I can get it to start again without crashing, then I hit “unclaim” on my photon (because for some reason resetting the app data doesn’t make it actually forget the old device, maybe because it is getting that information from the online account). Then I re-add the photon, and it still asks me “This photon is owned by another user. Change owner to moeburn@gmail.com?” - I don’t know what it means by “another user” because that IS me, and I am logged in as the original owner, but okay, I hit “change owner”. Then I tell it which wifi is mine, and enter that wifi’s password. I get a checkmark next to “configuring device wifi credentials” and “connecting to wifi network”, but when it gets to “verifying user credentials”, it crashes. Sometimes it also says “Uhoh, could not disconnect from the Photon’s internal wifi network”. Then it crashes. Then I can never start up the app again, because it crashes on startup, and the only way to get the app to start again is by wiping the app data.

And it does successfully configure the photon to my home wifi network, and I’m now able to get at the photon from the cloud IDE and everything. I just can’t use the Android app. At all.

Just for fun I tried the 10 second reset just now again, and got everything I just described.

UPDATE: Got the app working! I did two things. First I booted the photon to “safe mode” by holding both buttons, then releasing reset, then releasing setup while it was flashing magenta. Then I added the photon to the app while in safe mode. The app still crashed.

But then I went onto the cloud IDE and erased all the code I had entered in to play with before, and with the code section blank, I hit the flash button. It successfully flashed the blank code, and now the app works just fine without crashing! I was able to now use the app to reflash Tinker and everything! I have no idea why the 10 second reset button didn’t erase the code from the device, or why my code was somehow making the Android app crash completely (it was just a basic analog read a thermistor code), but after flashing blank code using the web IDE it’s all working great now. So I figure I’d leave this up for anyone else who has the same problem, since there seems to be a lot of people on the Play store reviews having the exact same problem as me.

1 Like

Because the Photon does not feature a Factory Reset to erase the code from it.

Glad to hear that it’s working for you again.