Android App Crashing

Hi. Trying to register a new Photon by using the Android app. After I log in it force closes. Tried on both MM and N.

I have tried clearing the cache of the app and logging out / logging back in. It still crashes.

Doesn’t seem to be the app, but rather the data it is retrieving - since I can duplicate the issue on two different Android platforms.

I just tried mine and it works just fine. There are know issues with the Android version of the app. It only works with certain devices and versions of Android. I have a HTC 10 running Marshmallow.

If this issue blocks you from setting up and claiming your device, you may want to do the WiFi setup via USB and claim the device via Particle Build - or you can do both with CLI.

So what I have found is that if you can hit the Plus Button and Add New Photon quickly enough, you can get to the setup section without it crashing.

Would really like the Particle Team to address and fix this issue. If you need any logs or additional information, I can certainly provide it.