I have a Core and Photon, both flashing green, tried flash --usb cc3000 no luck

I have a Photon connected via usb and when I run particle flash --usb cc3000 I get this:

Found DFU device 2b04:d006

Error writing firmware…no known App found.

I am not able to connect to the Photon via the app. I can connect to it using particle setup but after setup is complete it doesn’t connect to anything, just continues to flash blue.

I’ve spent the last 2 hours trying to fix them. I’ve tried everything and they’re both not getting passed the flashing green.

The odd thing is I had them setup on my home network a couple of days ago. I reset them both to demo setup for a class. While I was able to get them connected to my tethered phone at the time, I haven’t been able to get them back on my home network.

Very confused and frustrated. Hoping my students aren’t in a similar situation.

This is a command to update the TI CC3000 chip that is only present on a Core and not a Photon. This command should not work on a Photon, although a better error message would certainly be helpful.

Ok. So I tried this instead:

sudo npm update -g particle-cli && particle update

Afterwards I ran particle setup and couldn’t get through the whole thing because of this:

? Would you like to return this computer to the wireless network you just configured? Yes
! Network not ready yet, retrying…

! Network not ready yet, retrying…

! Network not ready yet, retrying…

! Network not ready yet, retrying…

! It doesn’t look like your Photon has made it to the cloud yet.

? What would you like to do? (Use arrow keys)
❯ Reconfigure the Wi-Fi settings of the Photon
Check again to see if the Photon has connected

The photon just keeps flashing blue. And then green when I hit reset.

Also… the Photon is showing up as Photon-CSVA but I get an error when trying to connect via the app:


Please try running setup again after resetting your Photon and putting it back in blinking blue listen mode if needed.

I solved it. After getting them both to work with my phone I realized there was something wrong with my local network. Not sure how that happened but everything is back up.

1 Like