How can I get Device ID?


Hi I’m Nednapa. I’m doing my senior project and I need your help. I set up my device and it told me to do it through the website. When I try to set up on the website. It show in the as the first picture. And I stuck there. Then I try to register my sim card and it shown as the second picture. So…

  1. Will I get the hex string if I done registration?
  2. If it need registration, is there a way to register without using credit card number?
  3. If all of this is my misunderstanding, can you please suggest me how to do?

ps. here is my email address REDACTED [MOD: Please don’t post your email address]

Thank you for your answer

You can find your device Id using these steps. That’s the hex string you mention.

1 Like

Thank you for your answer. But I’m still have a problem about credit card number. Is there a way that doesn’t use credit card?

Could you explain what the problem with the credit card number is?
I couldn’t get that out of any of your previous posts, you just said, it’s stuck there.

Have you not got a credit card?

For activating your SIM card, you won’t need the device ID, so your second screenshot has nothing to do with the SIM card.
The device ID is required to claim the device (not the SIM card) but for that your device has to be breathing cyan first, which it won’t unless you get your SIM card got activated.

2 Likes

Thank you for your answer.I can’t activate sim. It’s ask my credit card. I have no credit card what should I do.

You can either get a (prepaid) creditcard or try a different (normal) SIM card. You’ll have to enter their settings manually, but it should work just as well.

4 Likes

thank you

I use my sim card from my cell phone which has 2100Hz. So, how can I connect to cloud.

What kind Electron do you have? Is it compatible with your SIM`s band?
Have you flashed a code setting your SIM’s APN on your Electron?

Have you gone through https://setup.particle.io again and entered your SIM’s ICCID there?
If you did, you should have got this page, where you can download a binary to flash onto your Electron setting the corrected APN

1 Like

I have already done the step that you’ve told. Now I’ve already downloaded firmware.bin. But I can’t flash the firmware. I typed “particle flash 46005f00025135333735307 firmware.bin” but it couldn’t find firmware. So, I type “particle flash 46005f00025135333735307 C:\Users\Downloads\firmware.bin” but still not work. I also remove my simcard before I did this. I try “https://api.particle.io/v1/devices/46005f00025135333735307/” and didn’t work. Do you have any ideas what I should do?

Since you are not connected to the cloud flashing via the cloud cannot and will not work.

You need to do it via USB cable!

Put your device into DFU mode and run (when in the direcory where the file is located)

particle flash --usb firmware.bin

or via blinking blue Listening Mode (as it is clearly stated under points 4 and 5)

particle flash --serial firmware.bin
2 Likes

Now I can flash the firmware.bin and already complied the code(.ino) but I cannot flash them into device whether in listening mode or DFU mode. It said that I’ve to flash via OTA, but when I confirm the number like 0.005mb It still not work.Can you please help me?

What do you get when you try?

I got this when I try listening mode.And this in DFU mode

Didn’t I suggest to flash via USB?
What’s the output of the commands I’ve provided above? (especially the --usb one)

I clearly stated

And sir what is this mean. I try to flash the code again and it shows this and the light is blinking in purple.

That means that the version your binary is targeting (currently default 0.5.2) does not match the system version of your device.
You either need to update the device or target the correct system with your binary.

I try to flash via USB but it said that crc is invalid.

What version CLI and node are you running?

node -v
particle --version

I update it into version 0.6.0-rc.2 and already flashed tinker. Then, I flash my code in this way. Is this correct?