Particle identify command is missing ICCID of Electron

I am trying to get ICCID of Electron using Particle CLI. I followed the following steps:

  1. Put electron into listening mode (LED blinks blue)
  2. Particle Identify command on CLI

The electron returns only device id, IMEI and System firmware version.
Why ICCID is missing?

I have more than 100 electrons. All works fine without any issue. This happened first time. Is it an issue with SIM card? I am using Particle SIM.

The SIM card could just be loose.

Unplug the USB power and battery from the Electron. If it’s installed in a breadboard, carefully remove it. Be sure to lift it from both sides; if you pull up from one side only you can bend the pins on the other side.

Flip the Electron over and remove the SIM card. Gently push down on the metal band to make sure it’s tight. In rare cases you may want to use a pin to lift up the tiny metal prongs on the Electron, but this is not typically necessary.

Put the SIM card back in. The metal contacts on the card face the Electron, and the cut corner goes on the inside. Make sure it’s pushed all the way in.

i’m curious if it shows up in the console.

@rickkas7 Thanks for the response.
When I used the same SIM card in another Electron, i was able to see the ICCID in CLI. I did the same process of same SIM card with one more Electron, it worked again.

My guess is the Electron i used for first test is faulty. But i am confused about why that electron is returning IMEI and not the ICCID? I think both of this IDs are associated with the SIM card.

The IMEI is assigned modem hardware itself (it’s printed on the sticker and in the QR code on the modem module).

The ICCID is a property of the SIM card, so if there was a problem with the SIM card reader or circuitry connecting it, the ICCID command could still fail even if the SIM card itself was OK.